'Missing Operating System' on flash boot


Author
Message
Dibble
Dibble
New Member
New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)
Group: Forum Members
Posts: 10, Visits: 16
[solved; see last post]
I'm trying to create an image backup solution for a Dell Optiplex 380; it's a 32-bit system.

Reflect is installed and running fine; created a good image to an external drive. Now, I'm trying to create the boot media to a 16gb flash drive. It apparently completed ok. But, when I reboot the computer, right after POST (Dell logo screen) it just goes to black screen with a 'Missing Operating System' message.

The rescue environment is set in the wizard to:
Win PE 3.1
32-bit architechture
Default base WIM

I have:

1. created the bootable flash twice, the first time with the USB stick right out of the package new; the second by formatting FAT32
2. created the bootable flash again on a different, 32gb USB stick right out of the package.
3. verified in BIOS that USB device is first, SATA HDD is second (to make sure it's not trying to boot of of another media)
4. shut down, removed all other USB devices from the machine, pressed the power button. Aside from the missing keyboard error, I still get the 'Missing OS' message.
5. Installed the demo version of macrium reflect on another, 64-bit machine and created the boot USB with the same 16gb flash media; it works fine.
6. Returned to the 32-bit machine; relaunched Reflect from windows; rebuilt the rescue environment and created the media on the 16gb flash drive

Any other ideas?
Edited 3 August 2016 11:40 PM by Dibble
Richard V.
Richard V.
Most Valuable Professional
Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)
Group: Forum Members
Posts: 2K, Visits: 8K

You could try adding the rescue media build to your regular system boot menu to confirm that the WinPE build itself boots the machine properly.  See this KB article for details.  If the rescue build works okay when booting on your main OS drive, the problem has to be either the USB stick itself or some setting in your system's UEFI/BIOS configuration.  Is it configured for MBR booting or UEFI booting and is the so-called "secure boot" feature enabled?  Is the USB stick FAT32 partition marked Active?  Does that Dell OptiPlex model provide a special F-key selector to choose the boot drive during start-up?



Regards, Richard V. ("Arvy")
https://forum.macrium.com/uploads/images/afc5d4fe-5d25-4e25-be94-185e.png

Edited 3 August 2016 10:50 PM by Arvy
Dibble
Dibble
New Member
New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)
Group: Forum Members
Posts: 10, Visits: 16
Arvy - 3 August 2016 10:42 PM

You could try adding the rescue media build to your regular system boot menu to confirm that the WinPE build itself boots the machine properly.  See this KB article for details.  If the rescue build works okay when booting on your main OS drive, the problem has to be either the USB stick itself or some setting in your system's UEFI/BIOS configuration.  Is it configured for MBR booting or UEFI booting and is the so-called "secure boot" feature enabled?  Does that Dell OptiPlex model provide a special F-key selector to choose the boot drive during start-up?


Thanks for the suggestions. The WinPE build boots fine from the boot menu; So we've eliminated that.

For drill I checked for bios updates; upgraded from A05 to A07; That didn't help.

This machine doesn't support UEFI (too old); so the option in the Reflect wizard didn't even offer the option as the other/64-bit machine did. So, I'm guessing that means it's set to MBR by default. I checked all of the security sections in the bios and nothing was activated. During boot you can hit F2, which takes you to the bios settings; or F12 for a special 'one time boot screen'; options here are to boot from SATA drive, USB (this option shows when USB is enabled in bios), USB or internal optical drive, or network. Choosing USB here just gives me the 'missing os' message. choosing SATA gives me the menu with the option to boot to the macrium rescue media set up per the KB article you linked.

I have gotten this specific stick to boot the other machine, so the stick is good. And, once booted, the USB port used on the problem machine mounts the volume fine. So, the USB port is functional.

Still scratching my head on this one.
Dibble
Dibble
New Member
New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)
Group: Forum Members
Posts: 10, Visits: 16
Solution:

For the benefit of anyone else with this issue, for some reason Reflect was not setting the USB stick's recovery environment to the active partition.

In a command prompt run:
Diskpart
at the Diskpart> prompt run:
List Disk

Note the ID of the flash drive. Mine was noted as ID1 w/ 14gb of space

still at the Diskpart> prompt run:

Select Disk n (where n is your usb drive...in my case 1)

Select partition 1 (just selecting the first partition, nothing to do with the value of the drive ID as in the command above)

Active

Exit


The flash drive now boots the machine to the Reflect recovery software. Thanks.
Richard V.
Richard V.
Most Valuable Professional
Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)
Group: Forum Members
Posts: 2K, Visits: 8K
For the benefit of anyone else with this issue, for some reason Reflect was not setting the USB stick's recovery environment to the active partition.

The "some reason" is rather the reverse of that explanation, I think.  The FAT32 partition was not set Active in accordance with this KB article's very specific instructions on how USB sticks are to be prepared for use as Reflect WinPE rescue media.


Regards, Richard V. ("Arvy")
https://forum.macrium.com/uploads/images/afc5d4fe-5d25-4e25-be94-185e.png

Dibble
Dibble
New Member
New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)
Group: Forum Members
Posts: 10, Visits: 16
Odd that the other computer did not require that, even of the same physical media.
Richard V.
Richard V.
Most Valuable Professional
Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)
Group: Forum Members
Posts: 2K, Visits: 8K
Not really odd.  It's just that UEFI boot systems and MBR boot systems work differently.  The KB article's instructions are based on the possibility that users might have either or both setups -- apparently a correct assumption in your case.

Regards, Richard V. ("Arvy")
https://forum.macrium.com/uploads/images/afc5d4fe-5d25-4e25-be94-185e.png

Edited 4 August 2016 12:17 AM by Arvy
Peter_E
Peter_E
New Member
New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)
Group: Awaiting Activation
Posts: 1, Visits: 1
Dibble - 3 August 2016 11:39 PM
Solution:

For the benefit of anyone else with this issue, for some reason Reflect was not setting the USB stick's recovery environment to the active partition.

In a command prompt run:
Diskpart
at the Diskpart> prompt run:
List Disk

Note the ID of the flash drive. Mine was noted as ID1 w/ 14gb of space

still at the Diskpart> prompt run:

Select Disk n (where n is your usb drive...in my case 1)

Select partition 1 (just selecting the first partition, nothing to do with the value of the drive ID as in the command above)

Active

Exit


The flash drive now boots the machine to the Reflect recovery software. Thanks.

Setting the partition to active (as above) worked for me. Clear instructions. Many thanks. Could be useful to include in the instruction manual and or with the rescue setup as a selectable option.

crofttk
crofttk
New Member
New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)
Group: Forum Members
Posts: 4, Visits: 225
Peter_E - 27 January 2018 7:16 AM
Dibble - 3 August 2016 11:39 PM
Solution:

For the benefit of anyone else with this issue, for some reason Reflect was not setting the USB stick's recovery environment to the active partition.

In a command prompt run:
Diskpart
at the Diskpart> prompt run:
List Disk

Note the ID of the flash drive. Mine was noted as ID1 w/ 14gb of space

still at the Diskpart> prompt run:

Select Disk n (where n is your usb drive...in my case 1)

Select partition 1 (just selecting the first partition, nothing to do with the value of the drive ID as in the command above)

Active

Exit


The flash drive now boots the machine to the Reflect recovery software. Thanks.

Setting the partition to active (as above) worked for me. Clear instructions. Many thanks. Could be useful to include in the instruction manual and or with the rescue setup as a selectable option.

Seems pretty clear in step 8 of the instruction manual on this page:  https://knowledgebase.macrium.com/display/KNOW/Preparing+a+USB+stick+for+Windows+PE
Edited 29 January 2018 1:26 PM by crofttk
jphughan
jphughan
Most Valuable Professional
Most Valuable Professional (4.3K reputation)Most Valuable Professional (4.3K reputation)Most Valuable Professional (4.3K reputation)Most Valuable Professional (4.3K reputation)Most Valuable Professional (4.3K reputation)Most Valuable Professional (4.3K reputation)Most Valuable Professional (4.3K reputation)Most Valuable Professional (4.3K reputation)Most Valuable Professional (4.3K reputation)
Group: Forum Members
Posts: 3K, Visits: 21K
I realize this is in the V6 section (although sometimes V7 questions are posted in the V6 section and vice versa), but for what it's worth, I just used the Create Rescue Media wizard on Reflect 7.1.2833 targeting a flash drive with a FAT32 partition I had deliberately NOT marked as active, and the wizard marked it as active as part of the file copy process.  Maybe that's new for V7?

Edited 29 January 2018 3:02 PM by jphughan
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Reading This Topic

Login

Explore
Messages
Mentions
Search