Email notification server setting query. Connection type selection advice needed.


Author
Message
Nuser
Nuser
Junior Member
Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)
Group: Forum Members
Posts: 42, Visits: 99
Hi,
I am in the process of setting up my first email notification of a success/failure of a backup. I was pleased to successfully receive the automated test email.
What I want to know is which choice is best in the Connection type field and how do you know what options you can use? I left it set on the (default?) Connection Type > Plain Text (No Security ). The other options are as follows: Secure Sockets (SSL/TLS) and Transport Layer Security (STARTTLS).  
Is this something you can determine by looking at your internet settings in Outlook or is Plain Text (No Security) the norm for most of us and sufficiently secure if only communicating with ones own computer? Thanks.

Gork
Gork
Guru
Guru (1.2K reputation)Guru (1.2K reputation)Guru (1.2K reputation)Guru (1.2K reputation)Guru (1.2K reputation)Guru (1.2K reputation)Guru (1.2K reputation)Guru (1.2K reputation)Guru (1.2K reputation)
Group: Forum Members
Posts: 563, Visits: 1.6K
It depends on the settings and capabilities of the SMTP Server (email server) you've set up for Reflect to connect to in order to send the email notifications.  This has nothing to do with the Outlook client.  (Though looking at the settings in Outlook, assuming you're using the same SMTP server in both Outlook and Reflect, could indicate a different protocol which may be used in Reflect.)  I am not familiar with STARTTLS but when I use any client (Outlook for instance) to send emails through the SMTP servers I use I connect via SSL.  One of the SMTP servers I use REQUIRES a secure connection and since the other allows it I figure why not keep connections between my computer(s) and the email servers secure.

EDIT:
A quick Google search leads me to believe that for all current intents and purposes SSL and TLS are the same thing.  I found http://serverfault.com/questions/523804/is-starttls-more-safe-than-tls-ssl which seems to indicate STARTTLS is not normally used for normal end-user server/client setups - but this link describes the basic difference.  I noticed a lot more information available on the subject when I performed a Google search of simply STARTTLS.

OPs can help other forum searchers by highlighting (✔) an answer that resolves the issue.

Edited 7 January 2016 10:24 AM by Gork
Richard V.
Richard V.
Most Valuable Professional
Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)
Group: Forum Members
Posts: 2K, Visits: 8K
It's not really a Reflect issue.  As Gork said, support for STARTTLS depends on the SMTP email server that you tell Reflect to use.  Some servers support it and some don't.  You can test whether yours does at https://www.starttls.info/ .  Links to other tests here.

Regards, Richard V. ("Arvy")
https://forum.macrium.com/uploads/images/afc5d4fe-5d25-4e25-be94-185e.png

Edited 7 January 2016 10:30 AM by Arvy
Nuser
Nuser
Junior Member
Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)Junior Member (83 reputation)
Group: Forum Members
Posts: 42, Visits: 99
Thanks Gork and Arvy for your very helpful explanations and directions. After reading your posts I tried SSL but currently it will only function as plain text. I'll give the ISP a ring and see whether this limitation is able to be altered. I appreciate your valuable assistance and helping me understand these  issues.
 Best regards, Nuser
Huntz
Huntz
New Member
New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)
Group: Forum Members
Posts: 8, Visits: 15
Hi.  Trying to set up email notifications using Microsoft Office 365 Exchange Server.  When I enter my Server address (which is shown in Outlook), I receive a message saying I need to Specify a Valid SMTP Server.  Does this feature not work with Office 365?  If it does, what SMTP address do I use?  Thanks!

Richard V.
Richard V.
Most Valuable Professional
Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)
Group: Forum Members
Posts: 2K, Visits: 8K
According to the relevant Microsoft info it should be "smtp.office365.com" if you have an actual Office 365 account.  If that doesn't that work for you, if it's a Microsoft Exchange account, see the note on that same linked MS info page.


Regards, Richard V. ("Arvy")
https://forum.macrium.com/uploads/images/afc5d4fe-5d25-4e25-be94-185e.png

Edited 6 June 2016 1:21 AM by Arvy
Huntz
Huntz
New Member
New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)
Group: Forum Members
Posts: 8, Visits: 15
Thanks Arvy.  I used the recommended server address and now I get the following message:  Last message from server: 530 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM   Any ideas why I am getting this?  I double checked and I am entering the correct password.  Also, it is definitely an office 365 (not exchange) server.

Edited 11 June 2016 8:13 PM by Huntz
Richard V.
Richard V.
Most Valuable Professional
Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)Most Valuable Professional (4.1K reputation)
Group: Forum Members
Posts: 2K, Visits: 8K
Dunno.  That message isn't showing a complete valid IP address for the SMTP server.  However, the main problem appears to be rejection on the basis of anonymous mailing.  Did you provide a valid address for the "Senders Email" in the default settings?  See this KB article.


Regards, Richard V. ("Arvy")
https://forum.macrium.com/uploads/images/afc5d4fe-5d25-4e25-be94-185e.png

Huntz
Huntz
New Member
New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)
Group: Forum Members
Posts: 8, Visits: 15
Yes, I did, in fact I used 2 different email addresses associated with the Office 365 account.  The MS page you linked indicated that a SSL (TSL) connection type is required and that the port should be 587.  When I change the Relfect Default connection type to SSL/TSL it changes the port to 465.  Running the test that way produces no result at all (just the hourglass). Trying to cancel the test makes the Default interface go gray ans Reflect becomes non-responsive.  If I change the port to 587, I get an "unknown protocol" message.

Huntz
Huntz
New Member
New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)New Member (9 reputation)
Group: Forum Members
Posts: 8, Visits: 15
Okay, here is what it took:  I had to change the server address to smtp.outlook.office365.com.  I also had to change the connection type to STARTTLS (I noticed that the "unknown protocol" message included a reference to SSL).  Reflect Defaults set the port to 25.  Bingo.  So the support page from Microsoft was very little help.  But thanks to you Arvy for trying to help!!

Edited 11 June 2016 8:47 PM by Huntz
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Reading This Topic

Login

Explore
Messages
Mentions
Search