SSD Rescue Media


Author
Message
BGregory
BGregory
Talented Member
Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)
Group: Awaiting Activation
Posts: 101, Visits: 237
I have a 250Gb internal SSD that I would like to use as rescue media instead of inserting a USB key every time. I know I can use the Windows Boot menu but I think it’s a waste of time since it has to reboot a second time after selecting the Rescue option. On the SSD I created a small FAT32 partition and made it active and it is AHCI so it’s a ‘removeable’ device but it does not show up in the Rescue Builder. I’m sure there is some other restriction but I don’t know what that may be other than it's not USB or CDROM.

Thanks... Bob Gregory

jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)
Group: Forum Members
Posts: 4.9K, Visits: 36K
A few notes here:

1. AHCI does not cause SSDs to be exposed as removable storage devices. It just means there isn’t a RAID controller sitting in front of the storage.

2. Rescue Media is not limited to building to removable storage targets. It can build to USB fixed disk class devices, but perhaps not internal storage.

3. You shouldn’t have to reboot a second time to use the recovery boot menu option. Open MSConfig and select the Boot tab and make sure the boot menu timeout is set to a non-zero value. That will cause it to be displayed before any OS loads, so if you want the Rescue environment, you can select it upfront. I have mine set to 3 seconds because that’s long enough for me to select Rescue when I want it but not long enough to be an inconvenience.
Edited 20 January 2019 4:52 PM by jphughan
BGregory
BGregory
Talented Member
Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)
Group: Awaiting Activation
Posts: 101, Visits: 237
jphughan - 20 January 2019 4:50 PM
A few notes here:

1. AHCI does not cause SSDs to be exposed as removable storage devices. It just means there isn’t a RAID controller sitting in front of the storage.

2. Rescue Media is not limited to building to removable storage targets. It can build to USB fixed disk class devices, but perhaps not internal storage.

3. You shouldn’t have to reboot a second time to use the recovery boot menu option. Open MSConfig and select the Boot tab and make sure the boot menu timeout is set to a non-zero value. That will cause it to be displayed before any OS loads, so if you want the Rescue environment, you can select it upfront. I have mine set to 3 seconds because that’s long enough for me to select Rescue when I want it but not long enough to be an inconvenience.

JPH
1. Didn't know that
2. I actually do have some bootable USB fixed disk class devices that work fine with Rescue Media.
3. I do have the boot menu timeout set to 5 seconds but what happens is this:
    a. I boot fresh and get the blue menu with the Windows 10 and Macrium Rescue options.
    b. When I select Macrium the PC reboots and loads the Rescue environment.  I never thought the reboot was right so I've been using a USB flashdrive
       which I select from the one time boot menu evoked using the F12 key.  This way I only boot once.  Based on what you said I assume this second boot shouldn't
       occur.

Thanks... Bob Gregory
        
Wayne Powell
Wayne Powell
Junior Member
Junior Member (89 reputation)Junior Member (89 reputation)Junior Member (89 reputation)Junior Member (89 reputation)Junior Member (89 reputation)Junior Member (89 reputation)Junior Member (89 reputation)Junior Member (89 reputation)Junior Member (89 reputation)
Group: Forum Members
Posts: 34, Visits: 52
jphughan - 20 January 2019 4:50 PM
A few notes here:

1. AHCI does not cause SSDs to be exposed as removable storage devices. It just means there isn’t a RAID controller sitting in front of the storage.

2. Rescue Media is not limited to building to removable storage targets. It can build to USB fixed disk class devices, but perhaps not internal storage.

3. You shouldn’t have to reboot a second time to use the recovery boot menu option. Open MSConfig and select the Boot tab and make sure the boot menu timeout is set to a non-zero value. That will cause it to be displayed before any OS loads, so if you want the Rescue environment, you can select it upfront. I have mine set to 3 seconds because that’s long enough for me to select Rescue when I want it but not long enough to be an inconvenience.
I have mine set to 5 seconds ( I am a bit slower than you ) and most others as well. . Again thank you so much. If not on Macrium's payroll you certainly should be.  :-)

jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)
Group: Forum Members
Posts: 4.9K, Visits: 36K
Bob, the difference is that the boot menu option works by adding a new boot entry to Windows Boot Manager. In that setup, from a motherbord firmware standpoint, your system always boots from the same bootloader on your hard drive, which is Windows Boot Manager, and then it turns around and decides what OS to load from there. You don’t get a full system reboot though, otherwise you would see the menu option again. The setup you’re talking about is having a fully independent bootloader to allow your MOTHERBOARD to see the Rescue environment as a totally separate boot option, without loading Windows Boot Manager first at all. If you want to do that, then if you’ve already created a FAT32 partition and marked it as active, you can just manually copy the Rescue Media files to that partition and you should be good to go. If you have a UEFI system though, you might have some additional work registering that bootloader into the UEFI firmware, unless you’d be ok with it only being available from a one-time boot menu.

But the behavior you’re currently seeing with Windows Boot Manager is normal, and handling the boot menu option that way is a bit more convenient than having to muck around with one-time boot menus and/or BIOS boot orders whenever you want to boot the Rescue environment. The drawback to that method is that it relies on Windows Boot Manager being intact on the drive, which your attempted setup wouldn’t, but that scenario is meant to be covered by having “external” Rescue Media on a disc or flash drive.
Edited 20 January 2019 7:35 PM by jphughan
BGregory
BGregory
Talented Member
Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)
Group: Awaiting Activation
Posts: 101, Visits: 237
jphughan - 20 January 2019 7:26 PM
Bob, the difference is that the boot menu option works by adding a new boot entry to Windows Boot Manager. In that setup, from a motherbord firmware standpoint, your system always boots from the same bootloader on your hard drive, which is Windows Boot Manager, and then it turns around and decides what OS to load from there. You don’t get a full system reboot though, otherwise you would see the menu option again. The setup you’re talking about is having a fully independent bootloader to allow your MOTHERBOARD to see the Rescue environment as a totally separate boot option, without loading Windows Boot Manager first at all. If you want to do that, then if you’ve already created a FAT32 partition and marked it as active, you can just manually copy the Rescue Media files to that partition and you should be good to go. If you have a UEFI system though, you might have some additional work registering that bootloader into the UEFI firmware, unless you’d be ok with it only being available from a one-time boot menu.

But the behavior you’re currently seeing with Windows Boot Manager is normal, and handling the boot menu option that way is a bit more convenient than having to muck around with one-time boot menus and/or BIOS boot orders whenever you want to boot the Rescue environment. The drawback to that method is that it relies on Windows Boot Manager being intact on the drive, which your attempted setup wouldn’t, but that scenario is meant to be covered by having “external” Rescue Media on a disc or flash drive.

Thanks for the clarification JPH.
"If you want to do that, then if you’ve already created a FAT32 partition and marked it as active, you can just manually copy the Rescue Media files to that partition and you should be good to go"

I did do this but when I booted I got the "missing NTDLR" message so I just gave up.  I'm not using UEFI.

Bob Gregory
jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)
Group: Forum Members
Posts: 4.9K, Visits: 36K
Hmm, the reason for that could be your Windows Explorer settings. Some WinPE files are hidden and/or classified as protected OS files, so if your Explorer view isn’t set to show both of those categories, then when you select all to copy, you won’t truly be selecting all. The other thing that’s odd to me is that NTLDR was last used for Windows XP and was replaced by BOOTMGR starting with Vista, so I don’t think you shouldn’t be seeing that particular error at all. What OS did you use to set up this SSD you’re trying to boot from, including originally initializing it? I’m wondering if it might have an old MBR and/or partition boot code from having been set up from an older OS. Would wiping that SSD and setting it up again be an option?
Edited 21 January 2019 12:05 AM by jphughan
BGregory
BGregory
Talented Member
Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)Talented Member (183 reputation)
Group: Awaiting Activation
Posts: 101, Visits: 237
jphughan - 20 January 2019 11:27 PM
Hmm, the reason for that could be your Windows Explorer settings. Some WinPE files are hidden and/or classified as protected OS files, so if your Explorer view isn’t set to show both of those categories, then when you select all to copy, you won’t truly be selecting all. The other thing that’s odd to me is that NTLDR was last used for Windows XP and was replaced by BOOTMGR starting with Vista, so I don’t think you shouldn’t be seeing that particular error at all. What OS did you use to set up this SSD you’re trying to boot from, including originally initializing it? I’m wondering if it might have an old MBR and/or partition boot code from having been set up from an older OS. Would wiping that SSD and setting it up again be an option?

Thanks for the tip about NTDLR & BOOTMGR.  I used AOMEI Partition Manager to create, format, and set Active the partition.  I started over and used Windows 10 Diskmgmt.msc
instead and I can now boot from the SSD "rescue" partition.  Thanks for pointing me in the right direction.  I've used AOMEI for quite a while but never used it to to set a partition "Active"
which is the step I think that caused the problem.
Thanks again for the help with this

Bob Gregory

jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)Macrium Evangelist (7.2K reputation)
Group: Forum Members
Posts: 4.9K, Visits: 36K
Great! I’m not certain, but I don’t think setting the partition as active is the step that matters there because I believe that’s just setting a flag on the partition. I think initializing the disk (where you choose either MBR or GPT) and then creating and formatting the partition are the crucial steps because that determines the MBR boot code and then the partition boot code that get put onto the disk and then that specific partition, respectively. But again I’m not certain about that. I’ve also never done those tasks with third-party utilities, but I would think they’d have an option when performing those tasks for how to set up the disk/partition (maybe under an Advanced Options area?), such as Windows XP mode or Vista mode in order to deal with this. And Linux is an entirely different setup again if those tools want to support setting up a disk to boot those OSes, for example. Anyhow, it doesn’t really matter because as you’ve found, this stuff can be done with native Windows tools anyway. Enjoy!
Edited 21 January 2019 1:48 AM by jphughan
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search