Script running robocopy command doesn't ever complete, no log of any action taking place.


Script running robocopy command doesn't ever complete, no log of any...
Author
Message
HarryH3
HarryH3
New Member
New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)
Group: Forum Members
Posts: 5, Visits: 46
New Windows 10 Pro system.  New install of Reflect 7.1.  I'm using a VBS script, generated by Reflect, to run the backup and then start a .bat file that does a robocopy to a NAS drive.  However, the robocopy script never seems to start running, yet the scheduled task gets hung in the "Running" state.  The task is running as the user that has privileges to write to the NAS folder, and the script runs fine from the command prompt.  There is no indication in the Reflect log file that the script has been started.  Is there a log somewhere that might provide a clue as to what is preventing the script from running properly?  On the old system (XP Pro), running V5 of Reflect, a similar script would perform the backup and then open a command prompt window that showed the progress of the .bat file.  With the current configuration, no command prompt window opens and no copy gets done.  Is this a Win 10 thing or a Reflect thing?  I'd like to get this sorted so the backups will once again be performed automagically.  Smile

Thanks,

Harry


jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)
Group: Forum Members
Posts: 4.7K, Visits: 34K
Just to rule out an issue with the VBScript running as a scheduled task, does the VBScript run the batch file properly if you execute the VBScript directly?  If so, then given that you're comparing to a V5 installation, on your V7 system double-check under Edit Defaults > User that scheduled tasks are in fact configured to run as the user you want, because starting with V7, scheduled tasks default to running as the SYSTEM account.  I also don't think a scheduled task would be able to pop up a visible Command Prompt window at least on newer versions of Windows.  Even if you configured the scheduled task to run under the same account you're logged in under, scheduled tasks are executed in a separate context.

Finally, because you're new to V7, be aware that Macrium Image Guardian allows some Robocopy operations by default, but will block others.  Admittedly if you're using it to replicate onto a remote NAS share, you likely won't have any issues, but just in case, the KB article about this feature that explains Robocopy in detail is here.

Edited 2 October 2018 1:14 PM by jphughan
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search