Wake the computer to run this task not working


Author
Message
Stefan
Stefan
New Member
New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)
Group: Forum Members
Posts: 6, Visits: 5
I have the "Wake the computer to run this task" check box ticked.

The scheduled task is not running at the time when my computer is sleeping.

As soon as I wake my computer manually the overdue scheduled task runs.

Any ideas how I can get the scheduled tasks to wake the computer

jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)
Group: Forum Members
Posts: 4.7K, Visits: 34K
Are you sure your PC is still sleeping rather than having switched to hibernation by the time the scheduled backup window arrives?  Some power policies specify to sleep after, say, 30 minutes and hibernate after 180 minutes, and in those configurations, the PC will wake up from sleep to switch over to hibernation.  Scheduled tasks to my knowledge can't wake a PC from hibernation because the system is not drawing any power in that state, unlike sleep where the system is still running, albeit in a low power state.

Edited 17 July 2018 6:55 PM by jphughan
Stefan
Stefan
New Member
New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)
Group: Forum Members
Posts: 6, Visits: 5
jphughan - 17 July 2018 6:53 PM
Are you sure your PC is still sleeping rather than having switched to hibernation by the time the scheduled backup window arrives?  Some power policies specify to sleep after, say, 30 minutes and hibernate after 180 minutes, and in those configurations, the PC will wake up from sleep to switch over to hibernation.  Scheduled tasks to my knowledge can't wake a PC from hibernation because the system is not drawing any power in that state, unlike sleep where the system is still running, albeit in a low power state.

That must be it. Having checked advanced settings in the power plan, I see that Hybrid Sleep is turned on, Hybernate is turned off.

Never heard of hybrid sleep before but after a google search see that it is the default setting for a desktop pc whereas hibernate is the default for a laptop.

Current setting I have is for the computer to go to sleep after 30 minutes. Pushing the power button brings it back to life in seconds (SSD).

I guess that it is not possible to wake the computer up automatically when in hybrid sleep.

Thank you jphughan for answering so quickly.



Edited 17 July 2018 9:05 PM by Stefan
jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)Macrium Evangelist (6.9K reputation)
Group: Forum Members
Posts: 4.7K, Visits: 34K
I'm less sure that was it.  Hybrid sleep writes the current memory state to disk the way that hibernate does, but at that point instead of turning off all power, it goes into regular sleep mode.  The advantage to this setup is that if nothing goes wrong during this period, your system wakes back up quickly since it was only sleeping -- but if your system happens to lose power during this period, then the fact that your memory state was written to disk means that when the system starts back up, it will resume from the state saved to disk as if it had been hibernated all along.  The reason it's on by default for desktops and off by default on laptops is that a) desktops are more likely to lose power since they are less likely to have batteries or battery backups, and b) writing the memory state to disk can take a while, which might be an issue on a laptop because that consumes battery life and could also pose a thermal risk if a user just closes the lid and tosses their laptop into a bag assuming that it is already asleep.

Bottom line: If your system was in hybrid sleep and didn't lose power, then for wakeup purposes it should just be in regular sleep, so I would expect it to be able to wake up for that scheduled task.  But still, please report back as to whether your PC starts waking up as normal now that you've disabled that function

Edited 17 July 2018 10:09 PM by jphughan
Stefan
Stefan
New Member
New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)New Member (8 reputation)
Group: Forum Members
Posts: 6, Visits: 5
jphughan - 17 July 2018 10:08 PM
But still, please report back as to whether your PC starts waking up as normal now that you've disabled that function

I did not change the Hybrid Sleep setting because I like the way the functionality works.

However Macrium Relect schedules seem to be working fine now. I'm wondering whether it because I had two separate backups running C: drive first then later D:drive and I had "Suspend the computer when a backup task has completed" checked. I have unchecked this.

Or could it be that I now have a paid version of Macrium Reflect. I'm using incremental backups which I couldn't before.

dr.zapp
dr.zapp
New Member
New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)
Group: Forum Members
Posts: 1, Visits: 5
I'm having the same issue with Reflect 7.1 and 7.2. I have 4 similar Windows 10 systems, two of them work as expected, the other two don't wake up for the scheduled backup. The power and Reflect  settings are identical on all 4, I don't ever have them hibernate.
Edited 31 October 2018 6:10 PM by dr.zapp
cdsimon
cdsimon
New Member
New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)
Group: Forum Members
Posts: 5, Visits: 210
Several years ago, I had this problem with a new Dell XPS13. Although I really liked it, I returned it after 2 months of non-support from Dell and bought a similar PC from HP which wakes up faithfully from sleep or hibernation to run the scheduled backup. My problem appeared to be firmware related. On the HP the sleep menu under the Advanced power settings within power plan settings contains an “Allow wake timers” option that when enabled results in backup jobs running on the designated schedule. The Dell computer did not have the “Allow wake timers” setting. After much searching I concluded that there was no command to turn on the option. I keep checking on the XPS13s in Costco but they still don’t support “wake timers”. Other Dell models I’ve seen there, support “wake timers”.
Paul41
Paul41
New Member
New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)
Group: Forum Members
Posts: 1, Visits: 5
I was running into the same problem on a HP Windows 10 Home notebook. Upgrading to Macrium Reflect v7.2 made no difference. I recently made a change to the Windows power plan sleep settings and now the scheduled backup is running as expected.

Open the Windows Control Panel and go to "Hardware and Sound" and then "Power Options".
For your selected power plan click on "Change Plan Settings".
Then click "Change advanced power settings". You should see the Advanced settings box shown below.
Expand the "Sleep" item and then "Allow wake timers".
On my machine the "Plugged in" item was set to "Important Wake Timers Only".
I changed this to "Enable" and saved the change.
Now the scheduled backup is starting and running as expected to a localled connected external USB HD.
Apparently however Reflect is creating the Windows task item it is not being created as an important wake timer.



spilly80
spilly80
New Member
New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)
Group: Forum Members
Posts: 1, Visits: 5
jphughan - 17 July 2018 6:53 PM
Are you sure your PC is still sleeping rather than having switched to hibernation by the time the scheduled backup window arrives?  Some power policies specify to sleep after, say, 30 minutes and hibernate after 180 minutes, and in those configurations, the PC will wake up from sleep to switch over to hibernation.  Scheduled tasks to my knowledge can't wake a PC from hibernation because the system is not drawing any power in that state, unlike sleep where the system is still running, albeit in a low power state.

I know this is an old thread, but in case this helps others I did the following check this evening, under Win 10 (but I believe that it is equally valid under Win 7 and 8 too).
In short: Reflect will wake a PC from Hibernate or Sleep provided you enable Wake Timers on Advanced Power settings

Using Control Panel->Power options, I reset the current plan to MS default settings.
I then checked the Sleep settings Everything was set to Sleep, with Hibernate activated after 180 mins of sleep
I'm happy to accept this.
I then checked the Allow Wake Timers setting; On Battery Disabled; On Mains Power was set to Important Wake Timers Only
I googled to find a Tenforums article describing this (new) Win 10 feature. I read it to mean that only MS Windows services currently qualify as "important".  THEREFORE I changed the On Mains wake Timer to Enable and saved Power Options changes.
Next I started Macrium Reflect and scheduled an Incremental Backup to run once only in 10 minutes time; and closed Reflect.
I immediately Hibernated the machine, leaving it plugged in because that is a condition of my scheduled job.

Ten minutes later, the laptop fired up, ran the backup and re-hibernated (as set in Reflect Power Saving options), all just as it says in the manual

Hope this clears any doubts readers may have.


GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search