Can't update due to Image Guardian Service


Author
Message
stephen_c
stephen_c
New Member
New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)
Group: Forum Members
Posts: 23, Visits: 138
I've tried to update my Reflect from v 7.1.2817 to 7.1.2885, but each time I get a message telling me that the installer is unable to stop the Image Guardian service running.  The Image Guardian service has been stopped (confirmed with Task Manager) but it makes no difference.



I have downloaded the latest full installer and can remove my current installation but why should this be necessary?
My AVG internet security is (temporarily) disabled.
Thanks for your assistance.

jphughan
jphughan
Most Valuable Professional
Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)
Group: Forum Members
Posts: 3.2K, Visits: 22K
I’m not sure why you’re seeing this, but if it makes things a bit easier, you can run a Change installation from Programs and Features to remove just the MIG component, reboot, then run the full installer and choose to add it back. But if you’ve never done it before, even a full uninstallation is pretty painless since it defaults to keeping all of your settings, schedules, definition files, etc. The only thing I remember noticing a while ago is that the WinPE files downloaded from Microsoft are removed, so you’ll either need to download them again next time you try to build Rescue Media, or if the full installer download agent grabbed the PE Components zip file, those files will be added back during installation as long as that zip file is in the same directory as the installer itself.
stephen_c
stephen_c
New Member
New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)
Group: Forum Members
Posts: 23, Visits: 138
jphughan - 4 February 2018 1:52 PM
I’m not sure why you’re seeing this, but if it makes things a bit easier, you can run a Change installation from Programs and Features to remove just the MIG component, reboot, then run the full installer and choose to add it back. But if you’ve never done it before, even a full uninstallation is pretty painless since it defaults to keeping all of your settings, schedules, definition files, etc. The only thing I remember noticing a while ago is that the WinPE files downloaded from Microsoft are removed, so you’ll either need to download them again next time you try to build Rescue Media, or if the full installer download agent grabbed the PE Components zip file, those files will be added back during installation as long as that zip file is in the same directory as the installer itself.

I tried your suggestion and removed the MIG component, but it still wouldn't update. This time it told me that I didn't have sufficient privileges!
I conceded defeat and did a full uninstall and reinstall which went fine.
Thanks for taking the time to respond.  If anyone can shed any light on why I had the problem, I remain interested.
stephen_c
stephen_c
New Member
New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)
Group: Forum Members
Posts: 23, Visits: 138
I've now updated my laptop as well.  I hit exactly the same blocks as I had with my desktop, and only an uninstall and reinstall worked.
Both run the x64 version of Windows 7 Ultimate.

TG4711
TG4711
New Member
New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)
Group: Forum Members
Posts: 2, Visits: 4
Same system, W7 Ultimate X64, same issue.
Checking services in management console run with elevated privileges shows Image Guardian service is stopped, disabled and apparently cannot be changed as the dropdown list box that states "disabled" is greyed out and inoperative, looks like registry key permissions problems.
Have just removed my license key and uninstalled prior to trying re-install.
jphughan
jphughan
Most Valuable Professional
Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)Most Valuable Professional (4.6K reputation)
Group: Forum Members
Posts: 3.2K, Visits: 22K
On my systems, Image Guardian's service control buttons are greyed out, but it's running if I have it enabled in Reflect and both stopped and disabled if I have it disabled in Reflect.  I'm pretty sure the greyed out buttons are by design, and I’ve seen a few other services work this way.  You might have to run the Services snap-in as the SYSTEM account using something like PSExec if you want to control it that way, although obviously that shouldn't be necessary in the first place.

Edited 22 February 2018 4:03 AM by jphughan
TG4711
TG4711
New Member
New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)
Group: Forum Members
Posts: 2, Visits: 4
jphughan - 22 February 2018 3:55 AM
On my systems, Image Guardian's service control buttons are greyed out, but it's running if I have it enabled in Reflect and both stopped and disabled if I have it disabled in Reflect.  I'm pretty sure the greyed out buttons are by design, and I’ve seen a few other services work this way.  You might have to run the Services snap-in as the SYSTEM account using something like PSExec if you want to control it that way, although obviously that shouldn't be necessary in the first place.

You may be right about using the System account, Administrator did no good.  Uninstall and re-install was fairly painless bar the two re-boots.
Cannot now see what the status is as I unchecked the option to install Image Guardian as a PITA and the service is not installed.
Retained all settings and info, including license and WinPE files.  So, minimal grief BUT more than an hour wasted on what should have been a five minute update and as per usual, always when I pull the program out to use it.  So now down 2 hours for this.  Not sure why the installer could not work out that the service was already stopped.
Edited 22 February 2018 4:27 AM by TG4711
steve823
steve823
New Member
New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)
Group: Forum Members
Posts: 3, Visits: 6
stephen_c - 4 February 2018 1:06 PM
I've tried to update my Reflect from v 7.1.2817 to 7.1.2885, but each time I get a message telling me that the installer is unable to stop the Image Guardian service running.  The Image Guardian service has been stopped (confirmed with Task Manager) but it makes no difference.



I have downloaded the latest full installer and can remove my current installation but why should this be necessary?
My AVG internet security is (temporarily) disabled.
Thanks for your assistance.
I have this same problem. Everywhere I check the guardian service is already stopped. I tried downloading the file and installing from there with the same results. I tried rebooting, same problem. I tried unchecking the Guardian option on the install, but no difference there either. I've upgraded all the way from v5 on this machine and never had a problem with any of the updates.


Nick
Nick
Macrium Representative
Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)
Group: Administrators
Posts: 1.5K, Visits: 8.1K
steve823 - 1 March 2018 12:27 AM
stephen_c - 4 February 2018 1:06 PM
I've tried to update my Reflect from v 7.1.2817 to 7.1.2885, but each time I get a message telling me that the installer is unable to stop the Image Guardian service running.  The Image Guardian service has been stopped (confirmed with Task Manager) but it makes no difference.



I have downloaded the latest full installer and can remove my current installation but why should this be necessary?
My AVG internet security is (temporarily) disabled.
Thanks for your assistance.
I have this same problem. Everywhere I check the guardian service is already stopped. I tried downloading the file and installing from there with the same results. I tried rebooting, same problem. I tried unchecking the Guardian option on the install, but no difference there either. I've upgraded all the way from v5 on this machine and never had a problem with any of the updates.


Hi

Thanks for posting,  What version are you upgrading from?

Kind Regards

Nick - Macrium Support

stephen_c
stephen_c
New Member
New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)New Member (41 reputation)
Group: Forum Members
Posts: 23, Visits: 138
steve823 - 1 March 2018 12:27 AM
stephen_c - 4 February 2018 1:06 PM
I've tried to update my Reflect from v 7.1.2817 to 7.1.2885, but each time I get a message telling me that the installer is unable to stop the Image Guardian service running.  The Image Guardian service has been stopped (confirmed with Task Manager) but it makes no difference.



I have downloaded the latest full installer and can remove my current installation but why should this be necessary?
My AVG internet security is (temporarily) disabled.
Thanks for your assistance.
I have this same problem. Everywhere I check the guardian service is already stopped. I tried downloading the file and installing from there with the same results. I tried rebooting, same problem. I tried unchecking the Guardian option on the install, but no difference there either. I've upgraded all the way from v5 on this machine and never had a problem with any of the updates.


I suspect that you need to uninstall Reflect, reboot your PC and then reinstall using your downloaded installer.  It's pretty straightforward, your settings don't get lost.

What edition of Windows are you running?

I'm pleased to see Nick here; hopefully he will be able to identify why this happened.

GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Reading This Topic

Login

Explore
Messages
Mentions
Search