Unable to eject external hard drive


Author
Message
Stuart Tunstall
Stuart Tunstall
Talented Member
Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)
Group: Forum Members
Posts: 72, Visits: 155
Hi

 I am having an slight issue with ejecting the external hard drive I use for my Macrium backups... 

 If I click on the "safely remove hardware" icon in the taskbar and select my external drive I see this... even after a reboot.

..https://forum.macrium.com/uploads/images/fbedf10a-7d51-4a0f-b157-fc9b.jpg 

As this always used to eject OK, i am not sure if the latest Windows 10 update from Tuesday is causing this or the latest Macrium update... any ides? 

I have "unchecked" the indexing option for the external hard drive and that made no difference, and my normal USB flash drives will eject OK, just the external hard disc... 

Could the new image guardian cause this? as far as I know nothing else has changed...

Stuart
Nick
Nick
Macrium Representative
Macrium Representative (2.3K reputation)Macrium Representative (2.3K reputation)Macrium Representative (2.3K reputation)Macrium Representative (2.3K reputation)Macrium Representative (2.3K reputation)Macrium Representative (2.3K reputation)Macrium Representative (2.3K reputation)Macrium Representative (2.3K reputation)Macrium Representative (2.3K reputation)
Group: Administrators
Posts: 1.3K, Visits: 6.9K
Hi Stuart

Thanks for posting. 

We have identified a problem the the Change Block Tracker driver hold a volume lock. It is actually safe to eject the disk even though the message is shown.

An update will be made available shortly to resolve this problem. Apologies for the inconvenience. 

Kind Regards

Nick - Macrium Support

Stuart Tunstall
Stuart Tunstall
Talented Member
Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)
Group: Forum Members
Posts: 72, Visits: 155
Excellent, thank you Smile 

I guessed it must have been something that had changed and all I have really done is update Macrium and Windows Smile 

Look forward to the update Smile

Stuart
Stuart Tunstall
Stuart Tunstall
Talented Member
Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)Talented Member (128 reputation)
Group: Forum Members
Posts: 72, Visits: 155
Just opened the program to get an update patch... that is what I call GREAT and FAST customer support Smile thank you ....

Just tested connecting my external drive and it now "ejects" as it should...

Thanks again for the quick rectification of this minor issue Smile

Stuart


bitfidelity
bitfidelity
New Member
New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)
Group: Forum Members
Posts: 2, Visits: 2
I have this problem even though I'm running the latest version of Macrium. It began after I tested the "File and Folder backup" feature by copying a directory to my external drive. That backup has now been deleted, but Macrium is still "holding" the drive. Neither "Changed Block Tracker" or "Image Guardian" is enabled.
bitfidelity
bitfidelity
New Member
New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)
Group: Forum Members
Posts: 2, Visits: 2
Never mind, I was able to eject the drive after a restart. I guess a reboot was required for Image Guardian to release the drive.
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Reading This Topic

Login

Explore
Messages
Mentions
Search