Parameter "Run as possible" is ignored (0x800710e0)


Author
Message
Danylo
Danylo
New Member
New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)
Group: Forum Members
Posts: 11, Visits: 73

The Macrium parameter "Run task as soon as possible", it is not reported in the Windows scheduler.

On Windows Scheduler I see "<StartWhenAvailable>false</StartWhenAvailable>" instead of "true".

(see attachments)


If my PC was off, at the time of backup, this causes the error 0x800710e0 (also if the backup works well).

Also, on the Windows scheduler task I see  Task version="1.2"  (aka Windows Vista) instead of 1.4 (aka Windows 10).

WORKAROUND:
on Macrium I set "Run as possibile" = OFF.
Then I manual modified the Windows Scheduler:

  • <Task version="1.4"  
  • <StartWhenAvailable>true</StartWhenAvailable>
This solve the 0x800710e0 error on my  PC.

Macrium 7.0.2199
Windows 10 Home; Version 1703; Build 15063.540


https://forum.macrium.com/uploads/images/d9da4ef6-387d-4830-92c3-f8f0.jpg


https://forum.macrium.com/uploads/images/b9395e42-1c3a-48ae-81f6-15c8.jpg



Regards
Danilo








Attachments
Nick
Nick
Macrium Representative
Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)Macrium Representative (2.6K reputation)
Group: Administrators
Posts: 1.5K, Visits: 8.3K
Hi Danilo

Thanks for posting.

There is no functional difference between 'Task Version  1.2 and 1.4. 

The option 'Run tasks as soon as possible after a scheduled task is missed' is handled by 'MacriumService.exe' not by the Windows Task Scheduler.  If you are experiencing a problem with this then changing the Task to run as an Administrator user rather than SYSTEM can resolve the problem, however, as you already have a workaround then this probably isn't necessary. 

Kind Regards

Nick - Macrium Support

Danylo
Danylo
New Member
New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)
Group: Forum Members
Posts: 11, Visits: 73

I have tried your solution.

I set user = Danilo (admin). 

(this reset all Windows schedulers)


In all the tasks of Macrium I set:

- Run task as soon as possible = ON

- Wake the computer = OFF

- Daily

- start time = 05:00AM

(I want to exec the backup when I power on the PC)


RESULTS:

backup 2017/09/11  17:30 Successful

backup 2017/09/12  17:04 Successful

backup 2017/09/13  14:57 0x800710e0

Danilo 


GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Reading This Topic

Login

Explore
Messages
Mentions
Search