Macrium Support Forum

restoring a 2008 server with ver6 server no active partition

By TOB - 21 May 2016 7:59 PM

I just purchased  server v6 to back up and enlarge drives on a win 2008 server back up went well installed the new drives went well restore seemed to go well completed the redeploy (same machine only larger hard drives in raid 5 before and after)  redeploy seemed to go well

rebooted no loading from the hard drive
rebooted off of the usb key every thing seems to be there but both partitions are primary not active
went to fix boot windows problems reflect finds the win 2008 on drive C as it should be
go next and to select the active partition and it does not show any partitions to select to make active

need assistance  pls

By Nick - 21 May 2016 8:11 PM


Thanks for posting.  Sorry you are having problems.

Are you restoring to the same physical server?

What partitions did you backup and restore? 

Is it UEFI or MBR booting? This is important as there is no 'Active' partition for a UEFI system and when Windows PE boots in UEFI mode the Fix Boot problems options are different.
By TOB - 21 May 2016 8:38 PM

I am afraid that I am lost in how to find out what you are asking about UEFI and MBR I am there a way to tell or to correct this?

 I told it to do a full back up of all the drives c and d that was a raid system and completed the restore the same way but only larger partitions.

This is the same server I only upgraded the hard drives to larger ones both was operating in raid 5

I get no options in the 2nd window at all for the boot drive in the fix windows boot option

I have also sent this request in to support also maybe you can help me more that way my phone is also listed there
By TOB - 21 May 2016 9:17 PM

ok here is an update I think I have gotten lucky

I had labeled the original drives so I shut the server down reinserted them in correct order and the system did come back up and seems to be functional
now if anyone can tell me step by step how I should be backing up this system and any extra things that I need to look at or download, I will follow the steps closely this system needs to be back up 100% by Monday
By Nick - 21 May 2016 9:30 PM


Thanks for getting back. Glad to hear your system is booting. 

UEFI is supported by all motherboards shipped in the last 3 years or so and many earlier. Unlike legacy MBR; UEFI systems do not have active partitions. 
The partitions required to boot UEFI and MBR are described here:

It is important that you have imaged and restored the partitions required to boot Windows . Restoring just 'C:' and 'D:' isn't enough I'm afraid. 

If your Rescue media is booted in UEFI mode then you'll see "UEFI" in the application title bar.  If your Windows system is UEFI booting then you'll see an 'EFI System partition ' on your boot drive as described in the KB article above.  The option in Reflect to 'Create an image of the partitions required to backup and restore Windows' will automatically select the required partitions:

By Arvy - 21 May 2016 10:05 PM

@TOB -- You want  "step by step"?  It couldn't be simpler:
1) Create a backup image of the existing RAID array that includes everything.  That means EVERYTHING, including partitions that have no assigned "drive letter".
2) Shut down, replace the physical drives in the RAID array, and reboot to your Reflect rescue media in the same mode (likely UEFI) as your system boots.
3) Restore the entire backup image to the new setup.  That means ALL OF IT, not just the "larger" partitions.

That's it.  No need to run the ReDeploy function when merely replacing drives in the same machine.  If you do need to run the "Fix Windows Boot Problems" function for some reason, just be sure that you've booted the rescue media in the correct mode as mentioned in step 2.
By TOB - 21 May 2016 11:55 PM

this is becoming very stressing to me and I am letting it get the best of me and I hate this and I am sorry for being so worthless right now in this problem

I thought I did what you are explaining but I am getting no where
this machine is from 2011 if that helps any to know if it would have UEFI
in the 2008 server management there only shows 2 partitions C D no others also if I boot from the recovery usb there is no other partitions showing 
C shows as NTFS Healthy (system, Boot, Page file, active, crash dump, primary partition)
D shows as NTFS Healthy (Primary Partition)

if I run the macrium reflect from the hard drive of the server I do not see any mention of UEFI or from the usb stick none but after I restore the images I can see the data on both the C & D fromt the boot stick I have tried to repair the boot ant it does show the 2008 that it finds on drive c but nothing in the next box unless I keep the USB back up drive plugged in then it shows that drive bot NOT C or D

I did tell it to create an image of the partitions required to back up and restore windows and restored this also and there was no change in the results

in macrium it also shows that C is NTFS Active which is what I can not get the restored drive C to do at all in the restore image of booting from the stick the Drive C shows there as active before the restore from the image and after it gets restored then it shows C as primary only

I also did verify the data image and it is good
By Nick - 22 May 2016 12:17 AM

Hi Tony

Thanks for getting back.

Your original system is legacy MBR, this can be seen by the 'MBR' label on the disk:

I can also see from your screenshot that you are attempting to restore to a 3.27TB disk. This will not work as the maximum disk size for an MBR system is 2TB

During the restore process, Reflect will (and has to) automatically convert the disk format to GPT to cater for the the disk being larger than 2TB.
GPT disks require a UEFI booting motherboard and do not have an 'Active' partition. 

Unfortunately, it seems your system is limited to 2TB maximum disk size and isn't capable of booting a lager disk with UEFI.   Check your BIOS just in case. If you can boot UEFI then you need to follow these instructions:

However, because of the age of your M/B you probably won't have a UEFI boot option and cannot use a disk larger than 2TB to boot. 
By TOB - 22 May 2016 12:25 AM

so if I take the partitions to smaller than 2 will that work and if not if I change the raid to have smaller that 2 will that work ?
and why is it that the usb stick can show the files and the drives ?
By Nick - 22 May 2016 12:34 AM


Accessing the disk is not the same as booting. Windows Server 2008 and Windows PE can read GPT disks, but your Motherboard cannot boot from GPT. It's too old. 

Unfortunately, when running Windows PE (or Windows) it isn't possible to detect whether the BIOS supports UEFI or not. So, at restore time Reflect will convert the disk to GPT. 

so if I take the partitions to smaller than 2 will that work and if not if I change the raid to have smaller that 2 will that work ?
and why is it that the usb stick can show the files and the drives ?

You need to use a disk 2TB or smaller. It may work if you do not extend the restored partition beyond the 2TB boundary, but that will leave the rest of the disk completely unusable. If you create a RAID volume 2TB or less then that should work fine.