Macrium Support Forum

Please help, "not enough space on disk". Backup requires .57 Tb and there's 2.75 Tb free

By renarde - 3 January 2023 5:53 PM

Hi all, happy New Year and thanks in advance for your help.

I've been running Reflect for 5 years and have been very happy with it. Recently one of my backups has been failing. I'm using Reflect Home v8.0.7175 on a Windows 7 machine and trying to image a 2.44 Tb drive that has 576.77 Gb of used space. The 10.7 Tb backup volume has 2.75 Tb free, but the backup fails with the error "Backup aborted! - Write operation failed - There is not enough space on the disk.". All of my other backups (I have 9 total jobs on 4 different Windows machines) are running fine (many occur every night) and write to the same backup drive.

I've read similar posts in this forum and so far have not been able to find my solution. For example, I do not have another backup software running at the same time, and no other Reflect backups are scheduled when this backup occurs. I'm careful to make sure their run times don't overlap and no backup starts until the previous backup has finished. For example, the backup that is failing takes 2-3 hours to run, and has a 3.5 hour backup window when no other backups are running. It is my largest backup by a factor of 3.

The only thing that I can think of is that the backup volume is a Linux box with six 2 Tb drives. Maybe Reflect has an issue writing the backup image across multiple physical drives in a spanned volume?

I tried to attach the log file but the upload keeps timing out so I've pasted it below. I look forward to your telling me what I've missed!

Image ID - D685C80EDFCA0ED0
Imaging Summary
    Backup Definition File:    C:\Users\admin\Documents\Reflect\Backup_KaigenD.xml
    Auto Verify:    N
    Verify File System:    Y
    Maximum File Size:    Automatic
    Compression:    Medium
    Password:    N
    Intelligent Copy:    Y
    Power Saving:    N
    Email On Success:    N
    Email On Warning:    Y
    Recipients:    [email protected]
    Email On Failure:    Y
    Recipients:    [email protected]
    Total Selected:    576.77 GB
    Current Time:    1/2/2023 12:00:36 AM
    Backup Type:    Full
    File Name:    \\\Backups\Backups\Backup_KaigenD\Kaigen_D-00-00.mrimg
        Attempting to connect to: '\\\Backups\Backups\Backup_KaigenD'
        Successfully connected
Operation 1 of 1
    Hard Disk:    2
    Drive Letter:    D
    Volume:    \??\Volume{1b1fbc49-8f5e-4aa5-8b69-0f179bc5a09e}
    File System:    NTFS
    CBT:    Y
    Label:    KaigenD
    Size:    2.44 TB
    Free:    1.87 TB
    Used:    576.77 GB
Starting Image - Monday, January 02, 2023 12:00 AM
    Destination Drive:    Free Space 2.81 TB
    Free space threshold:    Delete oldest backup sets when free space is less than 5.00 GB
    Creating Volume Snapshot - Please Wait
Volume Snapshots Created
    D:\    \??\Volume{1b1fbc49-8f5e-4aa5-8b69-0f179bc5a09e}
Saving Partition - KaigenD (D: )
    Reading File System Bitmap
    Saving Partition
    Gathering Windows Events - Please Wait
Email Notifications
    Recipients:     [email protected]
    Email notification sent
    I/O Performance:    Read 3.1 Gb/s - Write 702.9 Mb/s
    Backup aborted! - Write operation failed - There is not enough space on the disk.

Macrium Reflect Home v8.0.7175
By jphughan - 3 January 2023 10:29 PM

I don’t think a spanned volume on the target would be an issue since Reflect wouldn’t even be able to determine that in a NAS scenario. The underlying storage is abstracted from network clients, and possibly even the OS depending on whether you’re using hardware or software-based spanning. Reflect also appears to correctly identify the free space at the beginning of the job, so something went wrong in the middle of the backup. If this is repeatable, would you be able to log into the Linux box and keep an eye on the reported free space during the backup, just to see if the Linux box itself reports less than expected free space? I’m not actually sure what this will look like on the Linux side, since new files that are still being written aren’t always counted against file system free space figures. But if free space drops well below what would be reasonable for this backup on its own, that would tell you something.
By renarde - 4 January 2023 1:41 AM

Thanks jphughan for your quick response, and for your thoughts about the spanned storage (it's software-based, BTW) which make sense.

I've talked to my boyfriend and we'll put together a bash script to write the free disk space that the NAS reports to a log file once a minute during the backup. Then we can see if it shows any dramatic drops in free space. I'll post an update once I have that info.
By renarde - 4 January 2023 10:27 PM

Hi jphughan et al, thanks again for your help.

The backup I've been having trouble with failed again overnight, so I tried running it today when I could watch it more closely. It ran for approx. 1.5 hours then failed with the same error message "Backup aborted! - Write operation failed - There is not enough space on the disk." I believe the job was ~80% completed when it failed.

Looking at the log file that we generated while the backup ran, the drive reached 79% used shortly before it failed, meaning, out of an 11Tb JBOD drive, 8.0Tb was used and 2.3Tb was free. Up until that point, the drive usage started at 74% used (2.8Tb free) and slowly crept up to 79% used (2.3Tb free). I can send the entire log file if you think it would be helpful.

Wed Jan 4 14:34:32 EST 2023
JBOD-Backups 11T 7.5T 2.8T 74% /mnt/backups
Wed Jan 4 16:07:32 EST 2023
JBOD-Backups 11T 8.0T 2.3T 78% /mnt/backups
Wed Jan 4 16:08:32 EST 2023
JBOD-Backups 11T 8.0T 2.3T 79% /mnt/backups

 Is it possible to capture more verbose logging for Reflect? Any thoughts about what else I can investigate?

Thank you!
By jphughan - 4 January 2023 11:38 PM

Hey April,

Sorry you're still having trouble. I don't know of a way for end users to get more verbose logs out of Reflect, but Macrium is certainly able to do so, and I've worked with them to chase down bugs using my system as a test case.  In terms of your error, if my memory from previous posts by Macrium Support on this forum is accurate, Reflect relies on standard Windows APIs to write to network locations (and local disks, for that matter), and it's even possible that the free space error message is an error that was actually thrown by Windows and passed up to Reflect, which it's then displaying, as opposed to an error generated by Reflect itself.  My main suggestion at this stage would be to see if Macrium themselves respond here -- fyi the Macrium Support reps who are active on this forum are the actual developers, not typical customer service reps with little to no technical training -- or else open a formal support ticket with them if you don't get a response quickly here.  They tend to respond very quickly and helpfully, especially if you're able to work with them to gather more information from your system.  And if the cause does turn out to be something with Reflect, a update to resolve that issue typically arrives very shortly thereafter.  My gut says that this might come down to some sort of protocol-level glitch that leads to inaccurate free space reporting, but I definitely don't know for sure. Linux isn't my forte.  But out of interest, is your Linux box on the latest kernel release just in case there might be glitches of that kind?  Good luck!
By jphughan - 4 January 2023 11:42 PM

EDIT: Never mind. Underlying cause in the thread linked below was identified and resolved.

@renarde Well as soon as I finished that reply, I checked the other newly updated thread in this section and found that it reports a problem that seems very similar to yours. Here is the direct link.  Perhaps there's something on the Reflect side of this equation after all.  Hopefully one or both of you can work with Macrium to help them understand underlying cause and identify a fix. Smile
By renarde - 5 January 2023 1:24 AM

Hi @jphughan, thanks again for your quick response.

It looks like the author of the "Problem Imaging a 4tb drive to a Western Digital Cloud Server" realized that he had mistakenly set up the backup that was failing to use a drive with insufficient space. You've been kind enough to help me confirm that's not what's going on in my case.

At this point, unless one of the Macrium devs chimes in with another perspective, it seems I'll need to open a support ticket with Macrium so they can dig into the logs and see if there is truly some sort of protocol-level glitch.

By JoeA - 5 January 2023 10:58 AM

Hi @renarde

The message "There is not enough space on the disk" is an error received from Windows via the network share OS and normally indicates that a disk quota has been exceeded.

It isn't the same error as the disk being full, and the reason will possibly be a file system/user configuration, or some such. You'll likely receive the same error if the same amount of data is copied to the share using Windows explorer.
By renarde - 5 January 2023 3:50 PM

Joe Allen - 5 January 2023 10:58 AM
Hi @renarde

The message "There is not enough space on the disk" is an error received from Windows via the network share OS and normally indicates that a disk quota has been exceeded.

It isn't the same error as the disk being full, and the reason will possibly be a file system/user configuration, or some such. You'll likely receive the same error if the same amount of data is copied to the share using Windows explorer.

@JoeA, thanks, I appreciate your quick response. I have a couple of questions before I explore other options on my own. As far as you know, is there a limit to how much data a single Reflect backup job can handle, meaning, have I reached the operating limit of the software? Based on other tickets or internal Macrium knowledge, is there a maximum amount of data that a single job can back up? Just wondering.

It sounds like I have two possible options from here:
1) Educate myself about how Windows reads and handles disk quotas when the storage volume is a Linux NAS to see if I can figure out the problem.
2) Divide the content of my main document and music storage drive into two backups instead of one monstrous job, and see if that helps.

Thanks again
By jphughan - 5 January 2023 3:59 PM

I've seen people successfully back up 10 TB of source data in a single Reflect backup job, so even if that's the limit -- which I have no reason to believe it is -- you're nowhere near it.

Any quotas relevant to this scenario would be configured on the Linux side, since that's the side managing the storage.  Essentially they give you a way to say that a certain user is only allowed to store X amount of data on a volume, and once the total size of files stored by that user reaches that limit, any applications using that user's account to write more data are told that there's no more capacity, which is the error you're seeing.  (And now that Joe has posted that, I'm over here smacking my forehead for having been a Windows IT guy for 15 years and having quotas come up on various certification exams over the years, and not having thought of it here. Tongue )
By JoeA - 5 January 2023 4:34 PM

Hi @renarde

The limit is the maximum size of the file system being imaged, and for NTFS that's 8 Petabytes.

Macrium Reflect has no limit or restriction on the image file size. Any limit is imposed by the file system that the image is stored on.
By renarde - 5 January 2023 6:12 PM

@jphughan, thanks for continuing to assist and for those insights! That's *very* helpful, and gives me a place to start checking. We'll look into the mergerfs and user configurations on the NAS and see if there are any user limits that are causing problems.
In the meantime, to simulate the Reflect job I started a manual copy of all the data on the large Windows drive to the backup drive. I'm curious to see if it will also fail.
Since you've been in Windows IT for 15 years you've seen your share of WinOSes. I must admit - my favorite is still XP. It's more transparent to power users with a lot less clutter and obfuscation BigGrin
By jphughan - 5 January 2023 6:20 PM

Happy to help!  I had a soft spot in my heart for XP for a long time, but when I came back to it after having used Windows 7 for several years, it felt a little too much like stepping back into the Stone Age for my liking, and the default Fisher Price interface that seemed so shiny when it launched just looked goofy in hindsight.  And my IT side also biased me against that OS compared to its successors because as annoying as people found UAC to be when it was first introduced, it was responsible for something like a 90% reduction in successful malware attacks (this was of course before ransomware).  Turns out that having everybody run with full admin privileges all the time, without even requiring reauthentication for elevated operations, was a horrible idea from a security standpoint -- which had been obvious in the Linux and Mac world for quite a long time.  (That's why I thought the "I'm a Mac, I'm a PC" commercial that made fun of UAC was unfair, since Mac OS prompted for reauthentication during elevated operations too, which I regarded as a good thing.)  But when you're the de facto tech support person for all of your family, friends, and neighbors -- on top of the people you're paid to take care of full-time -- OSes that allow users to get themselves into a bunch of trouble and create a bunch of work for you don't tend to remain in your favor for very long after there are better solutions available. Smile

And as much as Windows 10 annoyed me for quite a while, now when I step back into Windows 7, there are too many features I've come to like and rely upon in Windows 10 to make me just as happy on Windows 7.  That's especially true in the PowerShell world, where MANY useful cmdlets have been introduced in versions since Windows 7.
By renarde - 5 January 2023 10:54 PM

True, UAC is very helpful for for preventing malware infections and keeping people from massively screwing up their Windows installs. Comes in handy and when you're tech support for family and friends Wink
I'll have to give PowerShell another try and see how it can make my life easier on my Win 10 machines Smile

My manual copy revealed that I had a handful of files (sent to my by friends) that had names so long that the storage drive generated error messages about their length. Otherwise, the copy completed successfully, so I don't think the backup was failing because of limits on the amount of space a user can use on the Linux backup volume.

If the regularly scheduled backup succeeds tonight then I'll know the problem was the excessively long file names. I'll keep you posted!
By renarde - 5 January 2023 10:59 PM

@JoeA thanks for your quick response and letting me know that Reflect doesn't have any backup file size limitations. And no offense, but if I get close to 8 Petabytes of data I'll be using something other than Reflect to back it up! Right now I've got about 35Tb of data and that's plenty.
By renarde - 7 January 2023 6:00 PM

@jphughan my regularly scheduled backup failed, so apparently I either missed a problem file or a long file name wasn't the issue.

We checked the user definitions on the backup drive and there were no size limits set. Just to confirm that's true I hand copied all of the uncompressed data on the drive I'm trying to back up to the backup volume, and was able to copy two full sets of data. Having done so, the available drive space on the 10.7Tb backup drive has dropped to 1.27Tb, over a terabyte less than when the backup jobs that I've been asking about were failing. In spite of that, other automated Reflect backups to the same backup drive have been completing successfully, including ones that ran early this morning and backed up data from the same drive. In short, user data limitations on the backup drive don't appear to be the problem. It appears to be something about the way the problem backup is configured, or what it's trying to copy.

So I determined how large each directory is, and created two new File and Folder backup definitions. Each contains roughly half the data on the drive, and both ran successfully overnight. While it's not the solution I was hoping for it seems to be working.

Thanks again for your help, and I hope you have a healthy, prosperous, happy 2023 Smile

By jphughan - 7 January 2023 6:38 PM

Hey @renarde, thanks for circling back with an update! Glad to hear you’ve got a solution that works, but it’s still strange that the original job didn’t work, since it sounds like it should have. If you’re so inclined, you might consider opening a formal support ticket with Macrium about this so they can work with you to gather more information about what’s going on. Macrium’s engineers are very good, so the most likely outcomes are that you’ll a) clearly understand why your original setup isn’t feasible (least likely in my opinion), or b) you’ll know what had to be tweaked to make it work, or c) you might uncover a Reflect bug that Macrium will then be able to issue an update to resolve. So whatever the outcome, I think there’s very likely value to be gained by sticking with this a bit. But I also understand that everyone’s time is finite, so if you’re happy with the setup you’ve got now and want to move on with life, that makes perfect sense too
By renarde - 7 January 2023 6:50 PM

Hi @jphughan, thanks again for your good suggestions. I did indeed open a support ticket on the 4th, and JoeA from Macrium responded saying he'd work with me through this forum. He's the one who pointed us at a filesystem/user configuration issue. My (very amateur) testing doesn't seem to support that conclusion.

I'm a firm believer in making sure I post solutions in my support threads to help others who run into similar issues, so I'm good with continuing to research this. If I bump my support ticket do you think someone at Macrium will help me dig into this further?
By Steveyg777 - 16 September 2023 6:52 PM

So did you ever get this fixed? I've had the same issue for a while now. It's ridiculous because it makes the app pointless.
By jimrf97 - 16 September 2023 8:41 PM

I have never heard of backing up that much data all at one time.

If 70% of it remains the same, then move it to another drive and use something like syncback on individual folders.

Leave main drive free for operating system and a few other key programs, i.e., office apps, etc.

For example I have 2 drives, one I code jakarta ee on, and use Freecad and python, and store images, that's D: drive.
On C: drive I have operating system and some key programs like Office and Mcafee antivirus installed.

I use macrium on the disk with the c: drive.  I use syncback with D: drive, but only sync the folder I know I currently wrote to or changed a file.
Of course all is still backed up to an external USB drive.

Just a suggestion, but I would consider thinking about doing it this way.  I would not want to ever backup even one TB all at one time. Syncback has a free version which works great and you can write backup scripts as well.
By Steveyg777 - 16 September 2023 10:50 PM

I don't see the problem to be honest. It's usual for someone to have a 1tb ssd system drive that may have a few of their favourite games installed on also.
I've probably got 800gb filled of my system drive. I used to back it up using MR without problems. Why is it a problem now?
I've seen fixes this year for MR that suggest could have been the problem for the OP. because I'm having the same problem though may suggest they aren't completely fixed though. I'm gonna have to raise a ticket and waste lots of time solving this.
By JK - 17 September 2023 12:55 AM

Just because you may be getting the same error message as OP doesn't mean that you have "the same issue".  I would suggest starting your own thread, and actually posting some information relevant to your case (starting with a copy of a log file, minus the license code at the bottom of the log, as well as information about your set-up).
By renarde - 17 September 2023 3:20 AM

@Steveyg777 Hi Steve, I never did receive feedback that seemed like a solution from Macrium support. That said, my workaround of dividing the backup of the whole drive into two backups for roughly half of the drive contents seems to be working fine. My suspicion is that if you are using a spanned drive as your backup location, the backup file must all fit on one drive within that span or it fails.

But I don't really have a way to confirm it, and since the workaround results in that backups I need I've moved on to other questions. Like where to find a good job as a Project Manager for tech projects that has decent benefits and work/life balance. Little things like that :-)

Good luck, I hope you get your issue sorted out.

By Seekforever - 17 September 2023 2:01 PM

@Steveyg777, I agree with @JK, start your own thread stating your specific configuration and log file.
The original of this thread pertained to a NAS setup; is yours?
There was also a comment from Macrium that the error pointed to a possible Disk Quota issue, not physical disk space; did you check that.