Macrium Support Forum

Missing Operating system

https://forum.macrium.com/Topic51641.aspx

By T4nkcommander - 26 August 2021 3:01 PM

I've been converting Windows 7 machines to VMs using Macrium for a few months now. viBoot was initially very helpful to ensure I got the right configuration settings for a successful boot, but today when I tried to use viBoot to launch a computer I've been working with for a long time, it tells me "Missing operating system", despite showing the correct drive as bootable in the edit menu:





This is a new error to me...anyone else seen this?
By T4nkcommander - 26 August 2021 3:52 PM

I tried an older backup, which had the other MBR partitions available on the boot sector. This image was able to boot:



Is there any particular reason why these sectors are required? They haven't been necessary when cloning VHDs.
By jphughan - 27 August 2021 12:34 PM

The screenshot indicates that the partition marked as active is the Recovery partition. On MBR disks, there can only be zero or one active partition, and if one exists, that is the partition the system will attempt to boot from when booting from that disk. If there are zero active partitions, then the disk is deemed non-bootable. I suspect if you marked the Windows partition as active in your first scenario — which can be done from Reflect Rescue Media, booted from an ISO within the VM — it would start booting even without the Recovery partition, but it definitely will NOT work with no partition marked as active. This isn’t specific to viBoot. It’s just how Legacy BIOS booting and MBR disks work.