Macrium Support Forum

WinPE 10: unable to access the network

https://forum.macrium.com/Topic5032.aspx

By Ruud Uphoff - 2 December 2015 9:18 PM

Backup location is \\mybooklive\macrium each partition its ownsub-directory. A user name and password is required for this resource.

With Windows PE (anyversion) Reflect is unable to browse the network. Folder Network remainsempty. In all versions, Reflect gets a correct IP by DHCP and the right gateway(which is also DNS)

However, up to PE version5, I could type \\mybooklive\macrium,got the dialog for user name and password, and next could access my back-ups. Under PE 10 there isno way to access the NAS. Whatever I specify, I get a message “invalid file name”. 

How to at least accessbackups using Windows PE 10.
Even better: How toget browsing the network work. (It never worked)

  

By wags1 - 3 December 2015 1:55 PM

One "gotcha" that I found when using a WinPE 10 boot drive is that when you enter the user name for a network share access you need to add ".\" in front of the user name. So, for example, if your user name is Dave you need to enter it as .\Dave. This is only when booting with a WinPE 10 boot drive and not under normal circumstances. It has something to do with the WinPE 10 implementation.
By Stephen - 3 December 2015 2:19 PM

Hi Ruud,

Thanks for posting.

Please see this article for more information on connecting to network shares in WinPE:

http://knowledgebase.macrium.com/display/KNOW/Accessing+network+shares+in+Windows+PE

Alternatively as Wags1 suggests please prepend .\ in-front of your username.


By Ruud Uphoff - 3 December 2015 10:56 PM

Why am I getting answers that hat nothing, nothing and nothing is about the problem I described. Is there PLEASE someone that can read my question, even if my English is not Oxford.
Answer 2 refers to a KB article, that teach me to do exactly what I told that DOES NOT WORK. I can not browse the network, and typing the RIGHT path like described in that article, results in what I told already: a message "invalid file name". I am nor asked for credentials, but get an error message.

Please can someone tell me what is wrong, after carefully read and understand my problem.
 
By Nick - 4 December 2015 12:59 AM

Hi Ruud,

Thanks for getting back, apologies for the confusion. 

Network discovery/browsing is complex and it's possible that Windows PE cannot perform the name resolution required to to enable it to 'see' your NAS when browsing the network. Your normal Windows OS may have a name cache that is mapped automatically when you browse but this will not be available to PE. If you open a command prompt in Windows PE and type:

ping mybooklive


This will indicate whether the name has been resolved. 

Windows PE 10 introduced some fundamental changes to networking and we had to modify the way connections to shares were made to accommodate. Apologies if you have already tried this but could you please confirm whether you receive the same error when mapping '\\mybooklive\macrium' to a drive letter when using using PE Explorer? And also whether entering the IP address, rather than the NETBIOS name, results in the same error?

Mapping a drive in PE Explorer is described here:

http://knowledgebase.macrium.com/display/KNOW/Resolving+network+issues+in+Windows+PE

Let us know how you get on, it will help us to understand the cause and rectify the problem. 
By Ruud Uphoff - 8 December 2015 8:56 PM

Hi Nick
Attemp to map the share result in an error message: "A specified logon session does not exist. It may already have been terminated."






By ddk - 11 May 2021 11:12 PM

I got this trying to map a network drive to a Windows PC share from within the Windows RE 10 boot environment.
I found I had to logon using PC\Username rather than just Username
I did try .\Username but that didn't work for me.