Macrium Support Forum

Trouble with windows guest. Guest additions just hangs and so I'm stuck with a tiny resolution

https://forum.macrium.com/Topic49505.aspx

By klepp0906 - 1 July 2021 1:36 AM

So with windows 11 looming I'm starting to weigh the whole "upgrade vs clean install" conundrum.  (curse microsoft for this) 

Part of my solution should I decide to go the clean install route was to have my final windows 10 macrium image bootable via viboot so I could use it to pull whats going to amount to a zillion registry modifications and programdata/appdata folders to restore application settings and reference my start menu layout etc.  You get the idea.

I had never used viboot in the past as I never had a reason to.  I'm seasoned enough with vmware but thats just new OS's installed from an clean iso.  Since viboot doesnt support vmware I figured nows a good time to see how virtualbox is as I wasnt interested in enabling Hyper-V.

Getting the image started was easy enough.  At that point it all goes downhill though.  Naturally everything I have running on my main pc murders a VM so after waiting a good long while for it to start up and calm down, I closed and disabled everything.

At this point I wanted to install the Guest additions as I assume thats virtualbox's equivalent to Vmware tools.   In this case necessary not only cause I couldnt copy/paste between host/guest but because I use a 4k display and so my image was stuck in a little 1024/768'ish square in the center of my screen.

I was able to add an optical drive to the virtual machine and get the guest additions iso mounted.   This is where things went awry.  About 3/4 the way through the install process it completely hangs the virtual machine. 

It stops on
Installing mouse driver ...
Executing "C:\Program Files\Oracle\VirtualBox Guest Additions\VBoxDrvInsta.exe" dri...

The guest is completely non responsive and I have to hard shut it at which point i tried again with the same result.

Anyone seen this?  Is there a solution?  Do I have to enable hyper-V and use that? (hope not but will if I have to).



By klepp0906 - 6 July 2021 5:13 PM

oracle boards moderator suggested a fix (for anyone who runs into a similar issue) that I should have thought of first but here we are.

uninstall all physical hardware drivers from the guest before installing guest additions. 

I havent tested it yet but if i were a betting man....

this may end up being problematic for my intended use-case but time will tell.  curse microsoft for deciding to make a windows 11