Macrium Support Forum

viBoot crashing a lot (almost constantly)

https://forum.macrium.com/Topic42318.aspx

By AngelicCore - 28 December 2020 7:25 PM

Hi All,

I decided to seek support for this issue as it is almost persistent with me - all the other features of macrium reflect work in some way or another except viboot which almost always crashes after a few moments.
I've tried this with multiple versions of formatted machines and even moved the mrimg files to a local disk to ensure that it is not network related.

The scenario for me is simple.
I select an image to create a viBoot image with.
I select the core count, memory and network options.
VM is created successfully and boots up.
I enter my password and windows desktop is visible.
Give it a few moments and the VM hangs.

Most of the time if it doesn't hang at first launch it will hang after restart.
The VM is unresponsive and I am unable to shut it down via Hyper-V nor viBoot - the only way for me is to Turn Off the VM then restart it.

I've checked the event viewer in windows to see if there are related errors and I suspect the following errors maybe related:

Error level events:
Source: Volsnap
The shadow copies of volume \\?\Volume{e90697b1-492f-11eb-bba2-5c879c87531a} were aborted during detection.

Source: mrcbt
The previous session did not finalize the tracking file on device \Device\HarddiskVolume11. The tracking file has been reset.
and again:
The checksum for the tracking file on device \Device\HarddiskVolume12 is incorrect. The tracking file has been reset.
The previous session did not finalize the tracking file on device \Device\HarddiskVolume12. The tracking file has been reset.
The checksum for the tracking file on device \Device\HarddiskVolume10 is incorrect. The tracking file has been reset.
The previous session did not finalize the tracking file on device \Device\HarddiskVolume10. The tracking file has been reset.

Source VDS Basic Provider:
Unexpected failure. Error code: [email protected]

All within a few seconds/milliseconds of each other.

Some information level events:
Device \Device\HarddiskVolume12 has been surprise removed (IRP_MN_SURPRISE_REMOVAL)
Device \Device\HarddiskVolume11 has been surprise removed (IRP_MN_SURPRISE_REMOVAL)
Device \Device\HarddiskVolume10 has been surprise removed (IRP_MN_SURPRISE_REMOVAL)
Device \Device\HarddiskVolume9 has been surprise removed (IRP_MN_SURPRISE_REMOVAL)
Received GUID_IO_VOLUME_DISMOUNT for device \Device\HarddiskVolume8
Service stopped.
Received GUID_IO_VOLUME_UNLOCK for device \Device\HarddiskVolume12
etc..


Please advise.

Thanks!
By AngelicCore - 28 December 2020 7:33 PM

Also would like to add that I've tested this on a second machine and it is exactly the same behavior.

First time boot is working fine.
after reboot the VM hangs around 5 seconds after entering windows and no amount of trickery is working to keep it alive.

I usually run it with the following specs in case this helps:

12 cores
8 GB Ram
No Network

The physical machine has the following specs:
24 cores
32 GB Ram

By Balaji - 29 December 2020 1:43 PM

Hi AngelicCore,

I am sorry to hear that you are having an issue with a viBoot VM.

Could you please confirm the free disk space of the Drive where viBoot Repository folder is located - Tools=>Options=>Virtual Machine Repository. By default it is in C:\

Thank you
Balaji
By AngelicCore - 29 December 2020 2:43 PM

Hi Balaji,

I have 15 GB free on the C drive.

Thanks!
By Balaji - 29 December 2020 3:13 PM

AngelicCore - 29 December 2020 2:43 PM
Hi Balaji,

I have 15 GB free on the C drive.

Thanks!

Hi AngelicCore,

Could you please create a Technical Support ticket https://www.macrium.com/contact
We would need further information to investigate this and it is easier via ticket system.

Thank you
Balaji
By AngelicCore - 29 December 2020 10:13 PM

Thanks Balaji - I have created a ticket as advised. #79268