Macrium Support Forum

OneDrive keeps inserting itself in the path to the XML file

https://forum.macrium.com/Topic27626.aspx

By pctutor - 18 January 2019 4:00 PM

Creating a new system image file as normal. Using v7.2.3957
When I look to where it is being saved, it says it is going to the Reflect folder under Documents.
But when I look at the path afterward, OneDrive is in the path:

I have unlinked OneDrive, and then uninstalled it, and restarted the computer. I have no need for OneDrive at all. But Macrium still shows it in the path to the XML file, and when the backup tries to happen overnight, it just comes back with an XML validation error:

How do I get OneDrive completely out of the picture?
Thanks -
By Merlin - 18 January 2019 4:50 PM

There must be a way to stop sharing the Documents\Reflect folder with OneDrive.
Go into OneDrive settings where you can choose the folders and de-select it.
By pctutor - 18 January 2019 4:56 PM

Merlin - 18 January 2019 4:50 PM
There must be a way to stop sharing the Documents\Reflect folder with OneDrive.
Go into OneDrive settings where you can choose the folders and de-select it.

OneDrive is unlinked and uninstalled. It no longer shows up in Add/Remove Programs. Prior to uninstalling, I unlinked it. This was all based on the instructions for unlinking/uninstalling here

By Merlin - 18 January 2019 5:05 PM

The other thing you can do is copy the xml to another location outside of Documents or any other place shared with OneDrive and point Reflect there.
From the Backup Definition files tab, press the green add button and add the xml from the new location and delete it from the old one.