Macrium Support Forum

All backup task status's Disabled after bootup

https://forum.macrium.com/Topic16076.aspx

By mikeLA - 2 August 2017 1:25 PM

Hi 

Everytime I start up my W10 PC and launch Macrium Reflect 7 HE , all my scheduled backup tasks are set to "disabled" status. Obviously it is easy enough to enable them manually, but have I missed a configuration setting, so they are Ready from launch?

My MR7 Home edition is v7.0.2199 , my OS is Windows 10 Pro 64bit, version 1607 and I have AVG  PC tune-up V 16.74.2.60831 set to ignore Macrium HE

Many thanks
Mike
By jphughan - 2 August 2017 3:33 PM

You definitely haven't missed a step since they absolutely should still be enabled after rebooting.  However, I believe that Reflect is only reporting what it sees from Windows Task Scheduler there, so it's possible that something else is affecting your scheduled tasks.  If it wouldn't be too inconvenient, you could try deleting a schedule entry from your definition file, saving it (so Reflect removes the corresponding Windows Scheduled Task) and then recreating that schedule entry to see if somehow the new scheduled task is created in a way that works as expected after rebooting.
By mikeLA - 4 August 2017 11:27 AM

Hi JP
Many thanks for your rapid response to my post. Much appreciated. I did what you suggested, and it worked Smile........for 1 day Sad  I didn't reply to you immediately because I thought it best to test the situation out over several days. I looked into the task scheduler, and selected the first Macrium task, which was the one I had deleted, saved then re-instated. On looking into the history log, it would appear the task was disabled the previous evening with 142 event ID. I have posted the XML code below
- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Microsoft-Windows-TaskScheduler" Guid="{DE7B24EA-73C8-4A09-985D-5BDADCFA9017}" />   
<EventID>142</EventID>  
<Version>0</Version>  
<Level>4</Level>  
<Task>142</Task>  
<Opcode>0</Opcode>  
<Keywords>0x8000000000000000</Keywords>  
<TimeCreated SystemTime="2017-08-03T19:36:12.571902700Z" />  
<EventRecordID>2557</EventRecordID>  
<Correlation />  
<Execution ProcessID="1660" ThreadID="4804" />  
<Channel>Microsoft-Windows-TaskScheduler/Operational</Channel>  
<Computer>ScanPC</Computer>  
<Security UserID="S-1-5-18" />  
</System>- <EventData Name="TaskDisabled"> 
<Data Name="TaskName">\Macrium-Backup-{21136801-3BAC-4678-B4E2-F0264A2FBDA6}</Data>  
<Data Name="UserName">System</Data>  
</EventData> 
</Event>
Unfortunately I'm out of my depth with MS OS events and how they created/triggered. Your help would be much appreciated.
Cheers, Mike 
By jphughan - 4 August 2017 2:34 PM

Hey Mike,

Glad I could help a little bit here! Unfortunately I'm out of my depth on Windows Task Scheduler too, but that might be enough information for other users or Macrium staff to diagnose the issue, and I doubt you'll be waiting too long to hear from either or both. But just to be clear, the task only executed once before becoming disabled? Best of luck!

-John
By Nick - 7 August 2017 9:46 AM

Hi Mike

The Task has been disabled by a process running with local SYSTEM account, quite probably a local service.  What Anti-Virus/Security software are you running?
By mikeLA - 7 August 2017 11:20 AM

Hi Nick

Thanks for your reply. My PC is running AVG Internet security V 16.151. 8013 and AVG PC tune-up V 16.74.2.60831 set to ignore Macrium HE

Cheers, MikeA
By Chris-G - 9 October 2017 6:13 PM

Hi,
Was there ever a solution to this?
I am now having the same problem of the Scheduled Tasks (5 of them) suddenly showing as disabled on what appears to be a completely random basis (every few days).  In my case it isn't related to bootup (not re-booted for 5 days) or sleep (multiple times a day).  It doesn't appear to be related to Antivirus scans.  (Windows Defender Periodic Scan is Off, Avast scheduled scan is Off and although Malwarebytes is setup for scheduled scans, the Macrium Scheduled Scans being disabled don't correlate to these scans.

By Jaybee - 12 October 2017 10:51 AM

I have EXACTLY the same problem.  I have a number of scheduled backups that all set themselves to 'Disabled' seemingly at random. Some of my backup schedules are daily, some weekly, some monthly but they all set themselves to Disabled at the same time. 

I have no idea what's causing this but it only started doing it in the last few weeks. I suspect it was after the introduction of the version with MIG on it? Something like that. Never had a problem before that version as far as I recall.

Running W7x64 here with Avast av. 

Thanks! 

By Chris-G - 12 October 2017 11:15 AM

Jaybee, you don't say which anti-virus you are using.  The reason why I ask, is that looking on Avast's forum, their latest release (17.7.2314) seems to have a problem with their Game Mode module, in that it screws up the task scheduler.  https://forum.avast.com/index.php?topic=209525.0
I've un-installed Avast's Game Mode module, and am now waiting to see if this has cured the problem.
Note: Both Macrium and Avast updated their software at roughly the same time so it's difficult to determine the likely culprit.  Also note this problem may also apply to AVG (I don't know if AVG has Game Mode) as Avast now owns and develops AVG.




By Jaybee - 12 October 2017 1:52 PM

Hi Chris, 

I'm using Avast (17.7.2314) - always update to the latest engine etc. I've got the entire Macrium folder in Programs excluded.  
Thanks for the link. That does look like it could well be the problem however Avast last updated itself on 3rd October and the Macrium issue happened this morning (did a cursory check and noticed my dailies were all disabled along with everything else) so perhaps not... 

I've just uninstalled Games Mode too.... fingers crossed! 



By jphughan - 12 October 2017 2:45 PM

Great find Chris! Strange (and disappointing) to see Avast straying from their core competency into side projects like “system optimization”, though. Optimizing Avast itself while a game is running would be one thing, but this seems far more broad. It reminds me that ZoneAlarm used to be great until it collapsed under its own bloat. I’ve always been very skeptical and wary of “system optimizer/performance booster” applications for fear that the side effects may make the cure worse than the disease. Then again, Microsoft now has a Game Mode built into Windows 10 Creators!
By Jaybee - 13 October 2017 10:05 AM

So far so good. This morning everything is still Enabled & Ready.... <fingers-crossed.gif> Smile 

Thread Update: As of 5th November all working 100% fine. Definitely the Avast Game Mode causing the problem. As soon as I disabled that everything worked as normal. Thanks all.