Macrium Support Forum

Restore backup image (RAID 1) to Virtualbox

By gazza1990 - 19 July 2017 12:29 PM

Hello all,
I have a problem restoring a macrium backup image of a Workstation with Windows 7 O.S. to VDI (virtual box).
With VirtualBox i create a VDI Disk, subsequently i use a Rescue Media ISO (WinPE 5_0) to restore the backup into VDI and this operation ends successfully. After that i run ReDeply without problems.

When i start my restored Virtual Machine, it crash while loading classpnp.sys Driver.
I suspect the problem might be RAID 1, but not sure of this.

Can someone help me? i read many discussion about that problem without find a solution.
Thanks to all
By jphughan - 19 July 2017 3:16 PM

What type of RAID 1 were you running at the source?  Did you have a hardware RAID controller or were you using software RAID?
By gazza1990 - 19 July 2017 4:14 PM

I have a hardware RAID controller. Workstation is a HP Z240T.
I'm not an expert of RAID systems, when i create rescue media with macrium, in drivers list there is "Intel Chipset SATA RAID Controller".
In device management, under storage controller, there is "Intel SATA RAID Controller" and under Disk Drive there is "Intel Raid 1 Volume SCSI Disk Device"
Thank you for the reply.
By jphughan - 19 July 2017 4:50 PM

Ok, in that case this should have worked, and others have restored images from RAID 1 systems onto single-disk systems without issue. I don't know about restoring into a virtual environment, but that shouldn't really matter.  ReDeploy should configure the restored Windows instance to stop using the RAID driver and start using whatever driver is appropriate for Virtualbox, which I'm betting is emulating some legacy hardware that Windows has supported natively for a while in order to maximize compatibility.  Did ReDeploy indicate that it had suitable drivers for everything in the Virtualbox environment?  But just as an idea, even if it did, if Virtualbox offers a driver package that can be manually loaded as opposed to just a packaged installer that requires the OS to be running in order to install the drivers, you could try supplying the Virtualbox storage controller drivers to ReDeploy for it to inject at that stage.
By gazza1990 - 20 July 2017 3:42 PM

Thank you for the reply.
Yes, ReDeploy indicate that it had suitable drivers, without error.
I would not know where to retrieve the virtualbox controller drivers to inject them to ReDeploy ISO.
I try to set both "SATA" and "SCSI" (this because device management -> Disk Drive there is "Intel Raid 1 Volume SCSI Disk Device", but the Storage controller il "Inte Chipset SATA RAID Controller" ) in  controllers in VirtualBox, but i have negative results.
In Virtualbox i can select only "AHCI" as type for SATA Controller, but i think that is supported from Windows 7.
By jphughan - 20 July 2017 4:04 PM

Yes, AHCI is supported in Win7.  If you change the storage type in Virtualbox though, you'd have to run ReDeploy again afterward (but not restore the entire image again) so that Reflect would see the different storage controller and re-adjust the drivers appropriately.  Either one should work, but you may as well try the other one and a second round of ReDeploy if the functional differences in Virtualbox between emulating SATA and SCSI aren't important for your purposes.

If even that fails, I don't immediately have any further ideas to recommend, but of course another forum member or Macrium staff member might pop in. Smile
By gazza1990 - 21 July 2017 10:20 AM

I try to set SCSI Controller in Virtual Box and run ReDeploy, but when i start virtual machine, it show me the EFI (Source Drive is set with GPT Partitioning with UEFI BIOS) console (it doesn't find the bootable media).
I try to ReDeploy with SATA Controller, in this case S.O. start to load Drivers, but stop when load CLASSPNP.sys.

Searching with google, I found that the error on the classpnp.sys driver is probably due to the controller, but I would not know how to fix it.

I try even to run the "Fix Windows boot problem" utility without success

I found a solution!
If i format the Virtual Disk (.VDI set with SATA Controller) in MBR and restore, with Rescue Media, only the Windows Partition from the source Disk (GPT Formatted), then run "ReDeploy" and "Fix Windows Boot Problems", it works and S.O. start.
I would like to understand why whit GPT partitioning (BIOS UEFI), Virtual Machin doesn't work.
By jphughan - 21 July 2017 3:22 PM

Windows 7 never properly supported UEFI booting.  On physical systems, it required the Compatibility Support Module (aka Legacy Option ROMs) to be enabled.  Typically that requirement means that the environment needs to boot in Legacy BIOS mode, since those options allow a UEFI system to boot either in UEFI or Legacy mode, but strangely Win7 does in fact boot in native UEFI mode to a GPT disk in that setup. However, the fact that it FAILS if the aforementioned option isn't enabled suggests it still has some dependency on a Legacy BIOS mechanism somewhere, and I suspect that dependency creates this problem in a hypervisor, which would only offer a "pure" UEFI environment. That said, it was never really an issue because Win7 didn't take advantage of any UEFI features anyway, so there was never a reason to set it up that way in the first place, except I guess if you wanted to install Windows onto a >2TB partition. In fact last I checked, the Win7 install media wouldn't even boot in UEFI mode unless you modify the names and locations of the EFI boot files.  I'm actually surprised you have a workstation with a UEFI installation of Win7.

Anyway, I suspect this imperfect UEFI support on Win7 is the reason VirtualBox's page discussing its EFI implementation specifically says that Win7 won't boot in UEFI mode:

Hyper-V won't work with Win7 in UEFI mode either, for what it's worth, although I do prefer it to other solutions because it being a Type 1 hypervisor means it tends to perform far better than anything else that runs on Windows and that would necessarily be a Type 2 hypervisor.