Macrium Support Forum

Restoring Differential made with version 7

https://forum.macrium.com/Topic12674.aspx

By Sherman39 - 31 March 2017 2:44 PM

I have Windows 10 Pro 64 bit and suddenly had an issue that windows itself could not repair. I therefore tried restore of a Differential created using V7 but a rescue disc made with version 6. The differential seemed to restore but windows would not boot.I had several differential some of which were created using version 6. Thankfully a version 6 differential   did restore and boot up, although this was several weeks old.

I also tried restoring using a rescue disc created in version 7 but again this seemed to restore but the restore would not boot. I am guessing but although the differential I tried to use was created in version 7 the linked full back-up was created in version 6.which is a problem
I thought, when I upgraded to version 7 that back-ups created in version 6 would be compaitible/restoreable.by version 7.
As it stands my PC is up and running albeit to a situation as it was a few weeks ago.
Any thoughts as to how I might get the v7 differential and the version 6 full to restore and be bootable.
All restores mentioned above were verified.
Thanks
Regards
Sherman39

By Froggie - 31 March 2017 3:56 PM

There is a FIX BOOT option available in the Recovery Media... did you try that?

By Sherman39 - 31 March 2017 4:12 PM

Thanks for the response. I did try the Fix Boot option but without success.
By Froggie - 31 March 2017 4:33 PM

Very strange, Sherman.  FYI... the backup formats did not change between v6 and v7 and I have restored many mixed (v6 + v7) backup chains without issue to date, using both v7 & v6 Recovery Media.

When you say unBOOTable... exactly what were the symptoms when you tried to BOOT after the failed restoration?
By Sherman39 - 31 March 2017 5:08 PM

Rather than booting into Windows when the Dell Logo appeared,  after a short period there was a message "Preparing Auto repair" "Diagnosing PC" Your PC did not start properly or words to that effect.
This was followed by a light blue screen with a couple of options, one was to restart the other advanced settings. I tried all the the options presented but to know avail.
As I said I have managed to restore the last  version 6 differential I did before upgrading to version 7.
I didn't really understand too well but I did read somewhere (Macrium Help I think) about a missing MRCBT.sys file but cannot now look to see if my version 7 had this missing, and caused the problem, as my restore put version 6 back. I will soon repeat the upgrade again to version 7 on my PC  but was hoping to resolve the issue, or at least understand it, first. I assume that any download will by now have been amended to include the missing file.
Thanks again for your help and any other suggestions would be appreciated.







By jphughan - 31 March 2017 5:47 PM

Interesting, there's another thread about this exact issue in the Disk Cloning section of the V7 forums.  Nick from Macrium has already posted there, so keep an eye on it.
By Sherman39 - 31 March 2017 6:02 PM

Thanks for that. I will have a look at the thread.
It occurs to me that perhaps the differentials prepared using V7 were missing the Mrcbt.sys and consequently although the restore reported as successful I could not boot as I now had this file missing.
Whereas the differentials prepared using v6 did not have this as a problem.
Hopefully that is really not a totally dumb observation!!!

By Froggie - 31 March 2017 6:23 PM

The MRCBT.SYS file only allows Reflect to collect a smaller amount of Incremental DATA for each image.  The format of that DATA is exactly the same as DATA collected without using that feature... that's why it may be restored by both Systems without issue.
By Sherman39 - 1 April 2017 11:51 AM

Thanks for the information Froggie.
 I do find it hard to believe it is a coincidence that the version 6 differentials restore with no issue but the differentials made after I upgraded to version 7 do not, Irrespective of which version 6 or 7 rescue disc I use.
Perhaps someone else may throw light on it or sadly I guess I will have to make do.

I must admit it makes me regret having upgraded to version 7 when I did, seems like a bit of a waste of money.
By Froggie - 1 April 2017 6:40 PM

Sherman, you can try this below if you think the MRCBT.SYS file, or lack thereof, was the cause of your problem...

First, make sure you have an image to go back to if you've done a lot of work with the older restore point... IMPORTANT!  Then mount the troubled DIFF image under your LIVE System and check to see if MRCBT.SYS is located in that mount point under WIndows/System32/Drivers.  If it is, that wasn't your non-BOOT problem.  If it isn't, you can try the procedure below to try and resurrect your DIFF time point.  Before you do that, identify (via browsing) a v7 time point that you know has the MRCBT.SYS file within it.

Restore your System to the problem DIFF time point.  While in the Recovery Media, mount an image time point that you know was right after your v7 upgrade.  Examine that mount point and see if MRCBT.SYS is located under Windows\System32\Drivers.  If so, copy that file to your just restored C:\Windows\System32\Drivers folder and reBOOT from the Recovery Media into your LIVE System... if the missing file was the problem, it should BOOT.

If it does, enter Reflect and use the update feature to get you to the most recent offered update (2089, I believe).
By Sherman39 - 2 April 2017 11:22 AM

Dear Froggie
Thanks again for your time and help.
My wife, it is actually her PC not mine, has called a halt to further experimentation. She is "happy" to use the restore from a few weeks ago, i.e. prior to initial V7 upgrade.
As her PC really only has light domestic use she is confident that nothing vital has been lost.
She/we have updated to the latest v7.2089 and are redoing full and differential back-ups.
Thanks again
Paul