Macrium Support Forum

Scheduled tasks will not run - Error 0x800702e4

By HadleyHope - 22 December 2016 4:18 PM

Reflect version - Home 6.3.1665
Windows version 10 Pro Anniversary Update 64 bit.

I have just reformatted my hard drive and reinstalled Windows, version 10 (March 2016), which after install updated itself to the anniversary edition.
I reinstalled Reflect and created a new image backup, with full and differential versions.  I can run the backup from the definition tab, but every time I try from the schedule tab it fails, no dialog or log, just a Last Result of 0x800702e4.

I have tried recreating the schedule and definitions.
I have tried reinstalling (repair) of Reflect after the windows update.
There is only one user on this computer, it is the administrator and it is a Microsoft account sign-in.  I tried converting the sign-in to just a local account and get the same error.
I have tried changing the Schedule user, when I put in my Microsoft sign-in (email address) it just gets converted to the local user name.
There is only one Macrium service running, it is named "Macrium Service".
I am connected to the internet!

Thanks Martin
By et_and_family - 22 December 2016 9:48 PM

I suspect the error code produced indicates that there is a problem with permissions of the user account used to set up the Reflect Schedules. Please use the following knowledge base articles below on how to change the default user to an account with Administrative privileged permissions.

Hope this helps

Regards, et
By HadleyHope - 22 December 2016 10:34 PM

I looked at the articles, no joy, the user that the scheduled jobs runs under is the same as shown by "whoami", and is me (the only user account and with admin privileges)

When I installed Windows it defaulted to a MS account, so the user name gets defaulted to the first 6 or so characters of the email, and the user in the scheduler is shown as COMPUTERNAME\hadle.

Reflect allowed me to change under settings my short name to the email address I used to sign on, but it just defaults back to the short name.

UPDATE 1: Corrected slash typo.
By Gork - 23 December 2016 8:13 AM

Assuming @et_and_family is on to something...

That should be a backslash as opposed to a forward slash.  The entry in the User Name field in Reflect -> Other Tasks -> Edit Defaults... -> Schedule -> Schedule User should exactly match the result of the whoami command.  My username is Kraygienz and my computer name is Xythos.  whoami shows xythos\krayg and that is exactly what is present in the User Name field in the User Name field in Reflect.  I also use a MS account.  I do believe that the Windows admin account used must have a password associated, and that should of course be entered in the appropriate field in the Reflect Defaults page I referenced above as well.

You could try making an update to the Reflect task directly in Windows Task Schedule which would trigger you to enter the admin username and password as a test just to see if the information is correct in Reflect and to see if that fixes the problem as well...
By HadleyHope - 23 December 2016 9:21 AM

Sorry the slash the wrong way round was a typo!

I have double checked, all the references to the user seem to match between whoami, task scheduler and Reflect.  Please note that the bottom task in the scheduler has the same author and runs without problems.

My Windows account does have a password, at the moment I sign on with a pin, but removed that.  It did not work before I changed to a pin nor does it work after I remove the in.  I selected properties in the task scheduler, clicked on Change User or Group, entered hadle and clicked on check names, which resolved to the full name.

Regards Martin
By HadleyHope - 23 December 2016 10:08 AM

This gets very strange!

Out of desperation, in Reflect I tried changing the schedule user to either SYSTEM or LOCAL, on both tries I got a long message about account and timings not being compatible, sorry did not jot down the exact error!

I then tried to change the tasks in the scheduler to SYSTEM or LOCAL, on both tries I got a message saying "Running a task under a group user account is supported only on Windows Vista or later. To run a task under a group account, you must upgrade this task to a Windows Vista task." I clicked OK, the user account changed but the task did not run.  I then changed the task back to my email address and got a popup for my local account (PROMETHEUS\hadle") asking for the password,  All this in the scheduler was done for the differential task.  Back in Reflect the task run!!! Though the full task still failed.

Back in the scheduler I went through the same process for the full task, changing to SYSTEM, getting the message about needing to upgrade the account, reverting back to my local account, getting asked for the password and finally verifying the task ran in Reflect.

No idea what has fixed it, from looking in Reflect and the Scheduler the Author, user etc. look exactly like my previous screenshot, I can only think that somehow the password did not take originally.