External Drive Can't Be Removed After 8.1.7280 Update


Author
Message
owensdj
owensdj
New Member
New Member (15 reputation)New Member (15 reputation)New Member (15 reputation)New Member (15 reputation)New Member (15 reputation)New Member (15 reputation)New Member (15 reputation)New Member (15 reputation)New Member (15 reputation)New Member (15 reputation)
Group: Forum Members
Posts: 11, Visits: 71
Windows 11 is unable to "eject" the external USB hard drive I use for Macrium Reflect backups after I installed the update to 7280.  It says the device is in use.  This was a bug in Macrium Reflect in the past and looks like there was a regression.
dbminter
dbminter
Macrium Evangelist
Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)
Group: Forum Members
Posts: 4.8K, Visits: 52K
Possibly something where CBT is holding on to volumes and not letting them go.  Towards the end of beta testing, an update to CBT was causing USB HDD partitions to be listed as In Use on attempts to remove drive letters when they weren't in use.  Maybe not everything in the CBT updates was caught.

Pawel Orl
Pawel Orl
Talented Member
Talented Member (180 reputation)Talented Member (180 reputation)Talented Member (180 reputation)Talented Member (180 reputation)Talented Member (180 reputation)Talented Member (180 reputation)Talented Member (180 reputation)Talented Member (180 reputation)Talented Member (180 reputation)Talented Member (180 reputation)
Group: Forum Members
Posts: 107, Visits: 7.9K
I confirm - the USB external drive cannot be removed  8.1.7280


dbminter
dbminter
Macrium Evangelist
Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)
Group: Forum Members
Posts: 4.8K, Visits: 52K
I may have encountered this during the beta testing of 8.1 but unconsciously didn't report it.  I had connected 2 USB HDD's around January 2nd that wouldn't Eject.  I just wrote it off as Windows being picky again as it's wont to not Eject some USB devices.  Like Samsung T5's.

jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (22K reputation)Macrium Evangelist (22K reputation)Macrium Evangelist (22K reputation)Macrium Evangelist (22K reputation)Macrium Evangelist (22K reputation)Macrium Evangelist (22K reputation)Macrium Evangelist (22K reputation)Macrium Evangelist (22K reputation)Macrium Evangelist (22K reputation)Macrium Evangelist (22K reputation)
Group: Forum Members
Posts: 14K, Visits: 85K
As a workaround, you could uninstall just the CBT component.  It might cause Differential and Incremental backups to take longer than they otherwise would, but the difference will depend on how frequently you make backups and the average size of files on the volume being backed up.  If you want to go that route, go to Programs and Features, select Reflect, click Change, select Modify in the wizard, uncheck CBT, and proceed through the wizard and restart when prompted.

dbminter
dbminter
Macrium Evangelist
Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)
Group: Forum Members
Posts: 4.8K, Visits: 52K
@jphughan


Some other testing done by another user seems to indicate the CBT driver update is the culprit for USB devices not Ejecting after installing 8.1.


https://forum.macrium.com/67528/PC-does-not-boot-anymore-after-81-upgrade?PageIndex=4
DFINO
DFINO
Junior Member
Junior Member (76 reputation)Junior Member (76 reputation)Junior Member (76 reputation)Junior Member (76 reputation)Junior Member (76 reputation)Junior Member (76 reputation)Junior Member (76 reputation)Junior Member (76 reputation)Junior Member (76 reputation)Junior Member (76 reputation)
Group: Forum Members
Posts: 43, Visits: 90
owensdj - 12 January 2023 1:23 AM
Windows 11 is unable to "eject" the external USB hard drive I use for Macrium Reflect backups after I installed the update to 7280.  It says the device is in use.  This was a bug in Macrium Reflect in the past and looks like there was a regression.

Same problem with Windows 10 Pro
dbminter
dbminter
Macrium Evangelist
Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)
Group: Forum Members
Posts: 4.8K, Visits: 52K
I cannot replicate the issue with 8.1.7282 on USB flash thumb drives and Samsung T7 USB SSD's.  Haven't been able to test a USB HDD, though.

Froggie
Froggie
Macrium Hero
Macrium Hero (2.8K reputation)Macrium Hero (2.8K reputation)Macrium Hero (2.8K reputation)Macrium Hero (2.8K reputation)Macrium Hero (2.8K reputation)Macrium Hero (2.8K reputation)Macrium Hero (2.8K reputation)Macrium Hero (2.8K reputation)Macrium Hero (2.8K reputation)Macrium Hero (2.8K reputation)
Group: Forum Members
Posts: 1.6K, Visits: 17K
I can confirm that this is an issue during the v8.1.x testing prior to Build#7280 and is definitely CBT-related.  It's too much trouble to walk back all the BETA test versions to see where it started... the Devs should be able to find this issue.

dbminter
dbminter
Macrium Evangelist
Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)Macrium Evangelist (7.7K reputation)
Group: Forum Members
Posts: 4.8K, Visits: 52K
It most likely started with the release of 8.1.7248.  That was the build where I had a CBT issue where it was keeping partitions "In Use" in Disk Management when attempting to remove drive letters from partitions.  It had not been present before 7248.

GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search