network


Author
Message
Frank Esposito
Frank Esposito
Proficient Member
Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)
Group: Forum Members
Posts: 222, Visits: 572
Hello --- not sure were this issue is, but this is the issue --- 

I run a xp system as a VM and it just for testing and some old code, so  for the most part the "free" version of reflect is fine for backup --- I don't recall the need to test the  boot recovery  but I did his last  update to my  surprise there was no network to the host OS  --  So, is it the "free" version of  reflect has no network support or is  it win pe? 

Does  network support have to be requested to include network  support? --- I tried download win pe 4.0 but i I kept getting a pop-up message to  download it --- my guess is that these older version of win pe are not download-able any more ---

Any insight on how to get network support  added would be appreciated  -- Thanks


jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)
Group: Forum Members
Posts: 10K, Visits: 65K
To my knowledge, Microsoft still hosts older WinPE versions for download, but I admittedly haven't tested that in a while.  In terms of network support, you don't have to specifically enable it, but you do need either your Rescue Media's WinPE environment to have native support for the network adapter, or else you'd need Reflect's Rescue Media builder to have added suitable drivers to the build.  The latter is going to be a challenge since you're using XP, because the oldest WinPE version that Reflect can use is 3.1, which is based on the Win7 kernel, and XP drivers tend not to work in Win7 and newer environments.  So ideally you'd want your hypervisor to use a virtual network interface that has XP drivers available AND that has built-in support within whatever WinPE version you use.  But you didn't specify the hypervisor you're using, so I don't know if there's any such adapter, or even whether your particular hypervisor allows you to choose different virtual network adapter models.

The only fallback solution would be to manually provide Rescue Media Builder with virtual network card drivers that are appropriate for the WinPE kernel you're building with.  That way you don't need native WinPE support, nor does it matter that the network drivers being used within the XP OS are incompatible, because you're supplying something else.  That's a bit more work, but it's doable.  But I'd try to see if you can find a setup that's natively supported first.

Edited 22 March 2021 4:38 PM by jphughan
Frank Esposito
Frank Esposito
Proficient Member
Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)Proficient Member (316 reputation)
Group: Forum Members
Posts: 222, Visits: 572
thanks for the info ---  I think that I have a driver for the network  (v) network card --- let me check it that would work ---  Thanks 


GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search