scheduled backup fails if previous backup failed - (due to power loss or sudden shutdown)


scheduled backup fails if previous backup failed - (due to power loss...
Author
Message
Pub
Pub
Junior Member
Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)
Group: Forum Members
Posts: 35, Visits: 66
I found a bug in Macrium v7.

1. Macrium scheduled backup starts & creates a file "backup_running" in backup folder
2. Power loss computer shutdown sudden
3. Power restored & computer turn on. The file "backup_running" is not deleted because it is only deleted at the end of the backup which did not complete because of shutdown
4. Future scheduled backups all fail: error 0x01 - Logs show error message "Backup failed, backup already running"

Please fix this in your code.
When computer starts check & delete any residual "backup_running" file so macrium does not think the folder is locked.
Nick
Nick
Macrium Representative
Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)
Group: Administrators
Posts: 2.2K, Visits: 13K
M - 11 January 2021 9:48 AM
I found a bug in Macrium v7.

1. Macrium scheduled backup starts & creates a file "backup_running" in backup folder
2. Power loss computer shutdown sudden
3. Power restored & computer turn on. The file "backup_running" is not deleted because it is only deleted at the end of the backup which did not complete because of shutdown
4. Future scheduled backups all fail: error 0x01 - Logs show error message "Backup failed, backup already running"

Please fix this in your code.
When computer starts check & delete any residual "backup_running" file so macrium does not think the folder is locked.

Thanks for posting.

The "backup_running" mutex file, if not locked, is deleted every time Reflect accesses the folder, this includes when Reflect starts.  If your backups are saved to a share/NAS then it's possible that there is a problem with a stale lock on the file.  This must be addressed by the OS that's holding the lock, in this case it's the NAS or OS hosting the share. 

Kind Regards

Nick - Macrium Support

Next Webinar


Pub
Pub
Junior Member
Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)
Group: Forum Members
Posts: 35, Visits: 66
Hi Nick
Bad news then.

The backup is on a normal pc internal drive papartition dedicated to macrium.
Not a nas or network or anything external.

Further bad news, I opened macrium to check the error and after opening it the backup_running did not get deleted as you say it should.

Further bad news, i was able to delete the file myself just using windows file explorer. It wasn't locked or permission denied. Just a simple delete.

So I think there is a bug here please can you log it.
The backup_running file should be deleted automatically by macrium engine..

Also separate suggestion.
When macrium scheduled backup fails (also when it starts) it should give user a windows notification so they know what's happening.

I only found out because I check the backup folder manually weekly

Would you like me to send any log file to help fixing?


Nick
Nick
Macrium Representative
Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)
Group: Administrators
Posts: 2.2K, Visits: 13K
M - 11 January 2021 10:19 AM
Hi Nick
Bad news then.

The backup is on a normal pc internal drive papartition dedicated to macrium.
Not a nas or network or anything external.

Further bad news, I opened macrium to check the error and after opening it the backup_running did not get deleted as you say it should.

Further bad news, i was able to delete the file myself just using windows file explorer. It wasn't locked or permission denied. Just a simple delete.

So I think there is a bug here please can you log it.
The backup_running file should be deleted automatically by macrium engine..

Also separate suggestion.
When macrium scheduled backup fails (also when it starts) it should give user a windows notification so they know what's happening.

I only found out because I check the backup folder manually weekly

Would you like me to send any log file to help fixing?


Thanks for getting back and confirming, We can now see how this situation could occur and a fix will be included in the next update. 

Can you check the 'Folder To Search' list in the 'Restore' tab. Does it contain the backup destination path?



Kind Regards

Nick - Macrium Support

Next Webinar


jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)
Group: Forum Members
Posts: 8.4K, Visits: 57K
M, sounds like Macrium is on the case for the backup_running issue. As for a Windows notification, Reflect already does that whenever it starts a job and whenever one finishes, whether successfully or otherwise. They use the standard Windows “toast” notification system. Not sure why you wouldn’t be seeing those. Do you maybe have Quiet Hours enabled, which would suppress Windows toast notifications?
Edited 11 January 2021 8:34 PM by jphughan
Pub
Pub
Junior Member
Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)
Group: Forum Members
Posts: 35, Visits: 66
Nick - 11 January 2021 1:56 PM
Thanks for getting back and confirming, We can now see how this situation could occur and a fix will be included in the next update. 
Can you check the 'Folder To Search' list in the 'Restore' tab. Does it contain the backup destination path?

Hi Nick

* I checked and yes the folder to search is definitely there & correct so must be a macrium bug for searching/deleting the file then also?
* ran scheduled backup manually after deleting that file & backup succeeded. "backup_running" file deleted successfully
(although I didn't lose electricity this time which is the cause of issue)

@jphughan I have windows notifications ON & no sorry quiet hours is disabled.
I get a lot of other windows notifications from other apps so I know it's working on windows.

Are there any settings in macrium to check for turning notifications on or off? I'm not getting any notifications at all.
* also suggestion for Nick. even if there are "backup started" & "backup finished" notifications.
There should be a 3rd notification triggered by the background macrium service after power loss which is:
"Last backup failed due to abrupt shutdown / other reason"
Then the user gets a notification immediately after logging into windows and can take action.

Edited 11 January 2021 8:47 PM by M
jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)Macrium Evangelist (12K reputation)
Group: Forum Members
Posts: 8.4K, Visits: 57K
I don’t remember any Reflect options for Windows notifications offhand, but I can’t check at the moment. If they exist they would be in the Edit Defaults interface though, so you may want to look through there. But as a general bit of advice I would suggest separating bug reports and enhancement requests rather than mixing them up in the same thread and continuing to add to them over the course of that thread. This forum has a Wish List section specifically meant to be used for the types of ideas you’re suggesting here
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search