After switching backup to Macrium Task Scheduler, 9:45 AM task starts at 9:50 AM.


After switching backup to Macrium Task Scheduler, 9:45 AM task starts...
Author
Message
dbminter
dbminter
Macrium Hero
Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)
Group: Forum Members
Posts: 1.7K, Visits: 18K
After installing 7.3, I decided to give the Macrium Task Scheduler a try.  Yesterday, I deleted my 9:45 AM backup for this morning from Windows Task Scheduler and created the same 9:45 AM backup for today in Macrium Task Scheduler.  I checked the Log and saw it had executed, BUT the Log says it started at 9:50 AM instead of 9:45 AM.  I checked the scheduled time in the Scheduled Backups and it does still say 9:45 AM for Thursday.


Is this something to look into?


Thanks!

jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (11K reputation)Macrium Evangelist (11K reputation)Macrium Evangelist (11K reputation)Macrium Evangelist (11K reputation)Macrium Evangelist (11K reputation)Macrium Evangelist (11K reputation)Macrium Evangelist (11K reputation)Macrium Evangelist (11K reputation)Macrium Evangelist (11K reputation)Macrium Evangelist (11K reputation)
Group: Forum Members
Posts: 8K, Visits: 55K
I don't suppose this happened more than once yet?  If not, might want to see how reproducible this is first just to rule out something that may have interfered with the task executing as scheduled.  My own normally scheduled backup ran late yesterday, but then I realized it was because my PC wasn't on at the normally scheduled time. Smile

dbminter
dbminter
Macrium Hero
Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)
Group: Forum Members
Posts: 1.7K, Visits: 18K
Good suggestion. I only configured one task as a test of Macrium Task Scheduler's efficacy.  Since it's a weekly task, it won't run again until next Thursday.  I'll convert tomorrow's 9:45 AM Friday task from a Windows Task Scheduler task to an MTS one and see if it runs tomorrow at 9:45 AM, 9:50 AM, or some other time.

L. W. "Dan" Danz
L. W. "Dan" Danz
Proficient Member
Proficient Member (273 reputation)Proficient Member (273 reputation)Proficient Member (273 reputation)Proficient Member (273 reputation)Proficient Member (273 reputation)Proficient Member (273 reputation)Proficient Member (273 reputation)Proficient Member (273 reputation)Proficient Member (273 reputation)Proficient Member (273 reputation)
Group: Forum Members
Posts: 159, Visits: 3K
dbminter - 15 October 2020 5:46 PM
After installing 7.3, I decided to give the Macrium Task Scheduler a try.  Yesterday, I deleted my 9:45 AM backup for this morning from Windows Task Scheduler and created the same 9:45 AM backup for today in Macrium Task Scheduler.  I checked the Log and saw it had executed, BUT the Log says it started at 9:50 AM instead of 9:45 AM.  I checked the scheduled time in the Scheduled Backups and it does still say 9:45 AM for Thursday.


Is this something to look into?


Thanks!

If you've followed my recent posts in Scheduling on this forum, you have seen that I have been poking into difficulties with waking sleeping or hibernated systems to perform backups.  In so doing, I stumbled across an oddity with WTS -- the actual Scheduler Task Library queue entry for a task scheduled by Reflect is actually scheduled for 30 seconds prior to the requested time.   Turning on history traces for the task, I have noted that the process of starting the task and getting the backup actually running takes almost all of the 30 seconds.
So there may be some hysteresis introduced by MTS that is not compensated when generating the entry as it is for WTS.  

At the same time, 5 minutes is awfully long time compared to 30 seconds, but lacking insight into the entries in the MTS queue, I can' tell.   Good luck.  I just wanted to make you aware of the anomaly with WTS scheduled entries. 


  L. W. "Dan" Danz, Overland Park KS  

dbminter
dbminter
Macrium Hero
Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)
Group: Forum Members
Posts: 1.7K, Visits: 18K
I was aware of the WTS latency.  I, too, had stumbled across this before.  By accident.

dbminter
dbminter
Macrium Hero
Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)
Group: Forum Members
Posts: 1.7K, Visits: 18K
Today's backup ALSO started 5 minutes OFF schedule.


Should I open a support ticket on this one?

phred
phred
Talented Member
Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)
Group: Forum Members
Posts: 81, Visits: 452

dbminter - 16 October 2020 3:28 PM
Today's backup ALSO started 5 minutes OFF schedule.


Should I open a support ticket on this one?

Granted that it sounds like a bug, but why don't you just set the scheduled time for five minutes before (or after) the time you want it to actually start? At least as a temporary work-around.
dbminter
dbminter
Macrium Hero
Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)
Group: Forum Members
Posts: 1.7K, Visits: 18K
There's argument for that temporary fix.  But, there's also argument to fix bugs, too.  Smile  After all, who's to say some backups don't run 5 HOURS off for someone else?

phred
phred
Talented Member
Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)Talented Member (111 reputation)
Group: Forum Members
Posts: 81, Visits: 452

dbminter - 16 October 2020 9:57 PM
There's argument for that temporary fix.  But, there's also argument to fix bugs, too.  Smile  After all, who's to say some backups don't run 5 HOURS off for someone else?
Ahhh ... the old "to be, or not to be."
dbminter
dbminter
Macrium Hero
Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)Macrium Hero (2.3K reputation)
Group: Forum Members
Posts: 1.7K, Visits: 18K
There's something else that may be buggy.with MTS tasks.  When they execute, there's no dialog asking to delay or execute the task.  There was normally a dialog with a countdown for 20 seconds that appears.  However, that may simply be a feature that was removed.


Another 5 minute delay on today's task.  I'm opening a support ticket on this.

GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search