cluster run error invalid cluster number error = 6


Author
Message
RJHaines
RJHaines
New Member
New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)
Group: Forum Members
Posts: 2, Visits: 6
Hi there,
I have an old PC that I want to image before I get rid of it.  It's over 20 years old and currently dual booting Windows 98 and RedHat linux 4 using V-COM System commander for dual boot.  The PC has a MAXTOR 15GB primary drive and Western digital 45GB secondary drive.  The system runs fine dual booting into both Windows 98 and Linux.
I pulled both hard drives out of the machine to image them from my Windows 10 desktop via an IDE/ATA to USB adapter and I started with the 15GB primary disk.  I am getting the error "cluster run error invalid cluster number error = 6" when I run the image.  
I ran chkdsk E: /r and chkdsk did the following repairs:
Microsoft Windows [Version 10.0.17134.1726]
(c) 2018 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>chkdsk e: /r
The type of the file system is FAT32.
Volume Serial Number is 3B21-15F5
Windows is verifying files and folders...
More than one IO.SYS entry in folder \.
Renamed to IO.SY0.
More than one IO.SYS entry in folder \.
Renamed to IO.SY0.
File and folder verification is complete.
Convert lost chains to files (Y/N)? y
12288 bytes in 3 recovered files.
Windows is verifying free space...
Free space verification is complete.

Windows has made corrections to the file system.
No further action is required.

4,186,656,768 bytes total disk space.
 39,227,392 bytes in 263 hidden files.
 10,280,960 bytes in 2,020 folders.
3,699,601,408 bytes in 33,331 files.
437,514,240 bytes available on disk.

   4,096 bytes in each allocation unit.
  1,022,133 total allocation units on disk.
  106,815 allocation units available on disk.

I reran the image backup and I'm still getting the same error message.  I know V-COM system commander does play some tricks to hide one OS from the other so I did make sure that the last boot was into Windows 98 which I think is what allows Windows 10 to see the FAT filesystem on the boot partition.

Any ideas on what to try next?  Thanks for your help!
Nick
Nick
Macrium Representative
Macrium Representative (3.5K reputation)Macrium Representative (3.5K reputation)Macrium Representative (3.5K reputation)Macrium Representative (3.5K reputation)Macrium Representative (3.5K reputation)Macrium Representative (3.5K reputation)Macrium Representative (3.5K reputation)Macrium Representative (3.5K reputation)Macrium Representative (3.5K reputation)Macrium Representative (3.5K reputation)
Group: Administrators
Posts: 2K, Visits: 12K
RJHaines - 16 September 2020 6:08 AM
Hi there,
I have an old PC that I want to image before I get rid of it.  It's over 20 years old and currently dual booting Windows 98 and RedHat linux 4 using V-COM System commander for dual boot.  The PC has a MAXTOR 15GB primary drive and Western digital 45GB secondary drive.  The system runs fine dual booting into both Windows 98 and Linux.
I pulled both hard drives out of the machine to image them from my Windows 10 desktop via an IDE/ATA to USB adapter and I started with the 15GB primary disk.  I am getting the error "cluster run error invalid cluster number error = 6" when I run the image.  
I ran chkdsk E: /r and chkdsk did the following repairs:
Microsoft Windows [Version 10.0.17134.1726]
(c) 2018 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>chkdsk e: /r
The type of the file system is FAT32.
Volume Serial Number is 3B21-15F5
Windows is verifying files and folders...
More than one IO.SYS entry in folder \.
Renamed to IO.SY0.
More than one IO.SYS entry in folder \.
Renamed to IO.SY0.
File and folder verification is complete.
Convert lost chains to files (Y/N)? y
12288 bytes in 3 recovered files.
Windows is verifying free space...
Free space verification is complete.

Windows has made corrections to the file system.
No further action is required.

4,186,656,768 bytes total disk space.
 39,227,392 bytes in 263 hidden files.
 10,280,960 bytes in 2,020 folders.
3,699,601,408 bytes in 33,331 files.
437,514,240 bytes available on disk.

   4,096 bytes in each allocation unit.
  1,022,133 total allocation units on disk.
  106,815 allocation units available on disk.

I reran the image backup and I'm still getting the same error message.  I know V-COM system commander does play some tricks to hide one OS from the other so I did make sure that the last boot was into Windows 98 which I think is what allows Windows 10 to see the FAT filesystem on the boot partition.

Any ideas on what to try next?  Thanks for your help!

Thanks for posting.

The error indicates that a file has a cluster run that's beyond the size of the FAT table. This situation should normally be corrected by chkdsk, but considering the source and age of the file system there may be other factors at play. 

I suggest you turn off file system verification by select the default option.  'Other tasks' > 'Edit Defaults' > 'Backup' > 'Verify File System' > 'Backup without verifying the file system', repeat the image then mount the image to confirm all is intact. 

Kind Regards

Nick - Macrium Support

Next Webinar


RJHaines
RJHaines
New Member
New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)
Group: Forum Members
Posts: 2, Visits: 6
Nick - 16 September 2020 8:49 AM
RJHaines - 16 September 2020 6:08 AM
Hi there,
I have an old PC that I want to image before I get rid of it.  It's over 20 years old and currently dual booting Windows 98 and RedHat linux 4 using V-COM System commander for dual boot.  The PC has a MAXTOR 15GB primary drive and Western digital 45GB secondary drive.  The system runs fine dual booting into both Windows 98 and Linux.
I pulled both hard drives out of the machine to image them from my Windows 10 desktop via an IDE/ATA to USB adapter and I started with the 15GB primary disk.  I am getting the error "cluster run error invalid cluster number error = 6" when I run the image.  
I ran chkdsk E: /r and chkdsk did the following repairs:
Microsoft Windows [Version 10.0.17134.1726]
(c) 2018 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>chkdsk e: /r
The type of the file system is FAT32.
Volume Serial Number is 3B21-15F5
Windows is verifying files and folders...
More than one IO.SYS entry in folder \.
Renamed to IO.SY0.
More than one IO.SYS entry in folder \.
Renamed to IO.SY0.
File and folder verification is complete.
Convert lost chains to files (Y/N)? y
12288 bytes in 3 recovered files.
Windows is verifying free space...
Free space verification is complete.

Windows has made corrections to the file system.
No further action is required.

4,186,656,768 bytes total disk space.
 39,227,392 bytes in 263 hidden files.
 10,280,960 bytes in 2,020 folders.
3,699,601,408 bytes in 33,331 files.
437,514,240 bytes available on disk.

   4,096 bytes in each allocation unit.
  1,022,133 total allocation units on disk.
  106,815 allocation units available on disk.

I reran the image backup and I'm still getting the same error message.  I know V-COM system commander does play some tricks to hide one OS from the other so I did make sure that the last boot was into Windows 98 which I think is what allows Windows 10 to see the FAT filesystem on the boot partition.

Any ideas on what to try next?  Thanks for your help!

Thanks for posting.

The error indicates that a file has a cluster run that's beyond the size of the FAT table. This situation should normally be corrected by chkdsk, but considering the source and age of the file system there may be other factors at play. 

I suggest you turn off file system verification by select the default option.  'Other tasks' > 'Edit Defaults' > 'Backup' > 'Verify File System' > 'Backup without verifying the file system', repeat the image then mount the image to confirm all is intact. 

Thanks Nick!

I turned off file system verification and the backup was successful.  I was able to mount and browse the image which worked fine.  I even tried VIBOOT and that worked booting into System Commander - couldn't boot into either OS - they hung during boot, but I'm pretty sure that's an OS incompatibility with Hyper-V issue.  I'm sure I can use VirtualBox legacy OS support and do a traditional restore with Macrium Rescue media if I ever needed to.

Thanks again!
  
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search