Possible bug in location of PE Repository in v7.2.4557


Author
Message
Pim
Pim
Proficient Member
Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)
Group: Forum Members
Posts: 116, Visits: 888
After updating to v7.2.4557 I was surprised that I was asked to download WinPE again when I wanted to build a new boot menu for the new Macrium version. This never happened to me before when updating, because the Rescue Media Builder (RMB) could always use the WinPE from an earlier download. After quite a bit of research I found that the PE repository has changed from C:\ProgramData\Macrium\Reflect\[Windows AIK or Windows Kits]\... to C:\Boot\macrium\[Windows AIK or Windows Kits]\... I am assuming this is incorrect, because the manual says its should be C:\ProgramData\Macrium\Reflect\[Windows AIK or Windows Kits]\... and there is no mention in the release notes. Furthermore, the folder ProgramData would be more logical for a repository.

This change also partly explains why there have been several posts about not being able to download the last 205 KB of the WinPE download. Although that occurrence cannot be explained by the location change, the location did trigger for everybody updating their rescue media having to download the WinPE components again, which presumably is a much higher number of users than normally would have been the case.

Edit: I also just noticed that the figure displaying the Macrium Rescue Environment in the user manual shows the wrong path for the WinPE 4.0 staging area. It should be C:\Boot\macrium\WADKFiles instead of C:\Boot\macrium\WA4KFiles.

Edited 1 December 2019 10:10 AM by Pim
JasonUK
JasonUK
New Member
New Member (10 reputation)New Member (10 reputation)New Member (10 reputation)New Member (10 reputation)New Member (10 reputation)New Member (10 reputation)New Member (10 reputation)New Member (10 reputation)New Member (10 reputation)New Member (10 reputation)
Group: Forum Members
Posts: 8, Visits: 81
To add to Pim's post above:

Windows AIK & WIndows Kits/10 folders are now created in C:/Boot/Macrium folder when you create Windows PE10 rescue media with v4557. Windows AIK & Windows Kits/8.1 are installed with a clean install of v4557 in C:/ProgramData/Macrium/Reflect. In previous build (v4539) everything was in C:/ProgramData/Macrium/Reflect so if you've just run the update patch and recreated rescue media you'll have Windows AIK & Windows/Kits/10 folders in two locations. Doesn't look right! Rescue environment does work though.



Edited 2 December 2019 7:12 AM by JasonUK
Pim
Pim
Proficient Member
Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)
Group: Forum Members
Posts: 116, Visits: 888
I have been wondering for some time now whether this thread has been picked up by Macrium. I could see that it had been read by two Macrium employees, but no reply was posted, which is in contrast with my past experience. I already planned to remind Macrium to follow up on this thread, when I was surprised today to see that Nick responded in another thread stating that the location of all PE downloads was changed to C\boot\macrium.

Oon the same day I wrote this thread I also started another one about the WinPE 10 boot.wim always being build. On that topic I have not received any response up till today either.

I would appreciate it if Macrium in response to a bug report at least acknowledges having read a post and telling what the situation is or that something is going to be investigated. I have invested a large part of a day investigating these two possible bugs, in order to try to give as detailed as possible information in order to make troubleshooting easier. In the past few months I have already reported and contributed to the resolution of at least 9 bugs. I always found the communication with Macrium very good, which is why I am willing to invest my time in troubleshooting and reporting possible bugs. Therefore, I was/am surprised that I have not received any response. Moreover, the answer I was looking for was posted 10 days later in Nick’s post in the other thread, not this one. Hopefully this is just this time. I am normally (very) patient when it comes to fixing a bug, but I would like to receive a reply that my report has been picked up so I know that my message has arrived. Like I said, I sometimes invest quite a bit of time troubleshooting an issue in order to be as detailed as possible to make it as easy as possible for Macrium to reproduce and troubleshoot.

With regard to this topic about the location of the PE repository: I think it would be better to include such a location change in the release notes. That would have saved me quite a bit of time, thinking that this was a bug, while it was a deliberate change. Also, this change is a deviation from the information in the manual and IMO already for that reason it has to be made known somewhere, before the manual is updated.

Edited 12 December 2019 3:31 PM by Pim
Gosha
Gosha
Macrium Representative
Macrium Representative (134 reputation)Macrium Representative (134 reputation)Macrium Representative (134 reputation)Macrium Representative (134 reputation)Macrium Representative (134 reputation)Macrium Representative (134 reputation)Macrium Representative (134 reputation)Macrium Representative (134 reputation)Macrium Representative (134 reputation)Macrium Representative (134 reputation)
Group: Moderators
Posts: 99, Visits: 866
Hello Pim,

Thanks for posting on our forum.

Our sincere apologies for the lack of a timely response to your posts.

The unnecessary download was an oversight on our part and we'll make sure that the release notes aren't missing anything as significant as the PE repository location change in the future.

Thank you for your continued diligence.

Kind regards
Gosha - Macrium Support

Next Webinar


Pim
Pim
Proficient Member
Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)Proficient Member (205 reputation)
Group: Forum Members
Posts: 116, Visits: 888
Gosha - 12 December 2019 4:18 PM
Hello Pim,

Thanks for posting on our forum.

Our sincere apologies for the lack of a timely response to your posts.

The unnecessary download was an oversight on our part and we'll make sure that the release notes aren't missing anything as significant as the PE repository location change in the future.

Thank you for your continued diligence.

Hi Gosha,

Thank you for your fast response and apologies. I appreciate it. I trust that the communication will be smooth and hence more effective again, as we were used to. Thanks also for your assurance that the release notes will include significant changes, such as a location change of the PE repository.

Because I did not know what was going on I had reverted to v7.2.4539 by restoring an image. I understood from Nick's post that perhaps the PE repository will be moved back to ProgramData. For now I will wait and see what you decide and skip v7.2.4557.

Thnaks again for your fast response.
Best regards,

Pim

Edited 12 December 2019 6:22 PM by Pim
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search