Timed out waiting for Agent shutdown


Author
Message
NJK-Work
NJK-Work
Proficient Member
Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)
Group: Awaiting Activation
Posts: 99, Visits: 330
Over the past week, I have had the following error happen twice on the same server that uses Macrium Site Manager for its image backups:

Failed to start scheduled Incremental backup of REDACTED on REDACTED using Definition "REDACTED" and Schedule "REDACTED" - Timed out waiting for Agent shutdown Please check the Site Manager for further information.

The job schedule is set to retry again after 10 minutes - and on the second attempt it works just fine.  I have never seen this error before.  Does anyone know what this means?  Why is it trying to shutdown an agent?  Wouldn't it want the agent running...not shut down?

Thanks
NK
Alex
Alex
Macrium Representative
Macrium Representative (515 reputation)Macrium Representative (515 reputation)Macrium Representative (515 reputation)Macrium Representative (515 reputation)Macrium Representative (515 reputation)Macrium Representative (515 reputation)Macrium Representative (515 reputation)Macrium Representative (515 reputation)Macrium Representative (515 reputation)Macrium Representative (515 reputation)
Group: Moderators
Posts: 275, Visits: 941
NJK-Work - 7 May 2019 1:07 PM
Over the past week, I have had the following error happen twice on the same server that uses Macrium Site Manager for its image backups:

Failed to start scheduled Incremental backup of REDACTED on REDACTED using Definition "REDACTED" and Schedule "REDACTED" - Timed out waiting for Agent shutdown Please check the Site Manager for further information.

The job schedule is set to retry again after 10 minutes - and on the second attempt it works just fine.  I have never seen this error before.  Does anyone know what this means?  Why is it trying to shutdown an agent?  Wouldn't it want the agent running...not shut down?

Thanks
NK

Hi NK,

This looks like an incorrect error message inside the scheduling code - what may be happening is that there's a timeout trying to create a backup. We've fixed some related issues inside the scheduler code in the upcoming Site Manager release - I've reviewed the code and this should no longer happen. If you can keep an eye on it and if there are still issues after the next update (Hopefully later this week), we can get a support case started to solve the problem.

Regards,
Alex

Kind Regards,

Alex

Macrium Development

Next Webinar

See our reviews on

Trustpilot Logo
Trustpilot Stars


NJK-Work
NJK-Work
Proficient Member
Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)Proficient Member (299 reputation)
Group: Awaiting Activation
Posts: 99, Visits: 330
Alex - 7 May 2019 1:59 PM
NJK-Work - 7 May 2019 1:07 PM
Over the past week, I have had the following error happen twice on the same server that uses Macrium Site Manager for its image backups:

Failed to start scheduled Incremental backup of REDACTED on REDACTED using Definition "REDACTED" and Schedule "REDACTED" - Timed out waiting for Agent shutdown Please check the Site Manager for further information.

The job schedule is set to retry again after 10 minutes - and on the second attempt it works just fine.  I have never seen this error before.  Does anyone know what this means?  Why is it trying to shutdown an agent?  Wouldn't it want the agent running...not shut down?

Thanks
NK

Hi NK,

This looks like an incorrect error message inside the scheduling code - what may be happening is that there's a timeout trying to create a backup. We've fixed some related issues inside the scheduler code in the upcoming Site Manager release - I've reviewed the code and this should no longer happen. If you can keep an eye on it and if there are still issues after the next update (Hopefully later this week), we can get a support case started to solve the problem.

Regards,
Alex

Thank you
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search