"Choose an Operating System" Screen After Windows Update


Author
Message
BigMac1
BigMac1
New Member
New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)
Group: Forum Members
Posts: 32, Visits: 48
Possibly a coincidence, but after installing the October Feature Update to Windows 10 (v.1809) the "Choose an operating system" screen appears whenever I restart. (I refer here to a normal restart, not a restart from the Reflect recovery environment.)

I rarely restart, so not a big deal. Nevertheless, I didn't enable this behavior in Reflect, and the screen did not appear prior to installing the update from Microsoft.

Can I prevent the "Choose an operating system" screen from appearing.?
jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)
Group: Forum Members
Posts: 10K, Visits: 65K
Open System Configuration (aka msconfig), go to the Boot tab, and change the boot menu timeout to 0.
BigMac1
BigMac1
New Member
New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)
Group: Forum Members
Posts: 32, Visits: 48
Thanks very much for your advice. That actually doesn't solve the issue at hand - it only prevents the "Chose an operating system" screen from appearing.

That screen normally appears when there is more than one operating system on the computer from which to choose. I don't believe it would appear at all if  the Reflect recovery environment was not available as a choice, and I don't recall requesting that the recovery environment should be added to the boot menu.
jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)
Group: Forum Members
Posts: 10K, Visits: 65K
Oh ok, well you didn’t actually specify what the choices on the menu were, or for that matter that any of them were unwanted. Some people want to keep the recovery menu option in their BCD without seeing the option at every boot, for example. But if you don’t want the recovery boot menu option to exist at all, then go to the Create Rescue Media wizard, select Windows Boot Menu, and select Remove. If that’s not the issue, can you provide a bit more info about what’s in your menu now and what you want to achieve?
BigMac1
BigMac1
New Member
New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)New Member (49 reputation)
Group: Forum Members
Posts: 32, Visits: 48
Thank you. It was necessary to click on the Remove button. The "No boot menu" radio button apparently applies to the recovery environment.
jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)Macrium Evangelist (15K reputation)
Group: Forum Members
Posts: 10K, Visits: 65K
Correct, the “No boot menu” option technically means “No boot menu item for Reflect Rescue”. If after selecting that you still had other items in your BCD, such as from a dual boot setup or having multiple boot modes for your single OS, then by default the boot menu would have continued to appear, despite that option’s wording. But if there’s only one BCD entry left at that point, then the menu is suppressed.
GroverMike
GroverMike
New Member
New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)New Member (1 reputation)
Group: Awaiting Activation
Posts: 1, Visits: 1
jphughan - 31 March 2019 10:14 PM
Open System Configuration (aka msconfig), go to the Boot tab, and change the boot menu timeout to 0.

I was unable to enter a 0; wanted 3-999. (I have Windows 10 Pro)

I found this on another website, it worked for me-
1. Press Windows + X, then Select System.
2. Click/tap on the Advanced system settings link on the left
3. Click/tap on the Settings button under Startup and Recovery.
5. Choose Windows 10 default and uncheck the option Time to display the list of operating system.

Edited 13 February 2021 8:46 AM by GroverMike
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search