New issue - running a scheduled full backup ran twice


Author
Message
MichaelP
MichaelP
New Member
New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)New Member (11 reputation)
Group: Forum Members
Posts: 10, Visits: 16
jphughan - 8 May 2019 2:15 PM
It's not the definition file that would "need" to be rebuilt, but rather the scheduled tasks that call that definition file.  Changing the user account that Reflect uses for background tasks does indeed cause it to go through and modify (maybe delete and recreate?) any existing scheduled task to use those new credentials.  You would NOT need to go through and recreate your entire definition file, which includes the other settings you want to use for the job, e.g. what data to back up, the destination, encryption/compressio, retention policy, etc.


Thank you for that. What you say makes sense. But at the same time it is noteworthy that just changing the scheduled time in the definition file enabled the backup, scheduled to run a little later in the day, to run successfully. So, there too, seems to be some "rebuild" going on. Unfortunately, the interface between Reflect and the Task Scheduler is a bit of a closed book.
I'll leave the account at SYSTEM (I believe this is the installation default in the latest version of Reflect) and see what happens with the next scheduled run on 03/06/2019. 

BobUlius
BobUlius
Junior Member
Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)
Group: Forum Members
Posts: 48, Visits: 52
Hi folks and Happy New Year.

Guess what's back? Smile
One of my two scheduled monthly tasks has been running twice each month for at least the last two months. Makes sense as Daylight Time changed the month before. But this time it has done the same run twice for two months so does not fix itself the second month. And the other monthly backup on the same computer but to a different destination only runs once.

Have we learned anything that can fix this since last posts?

Thanks.

~Bob


dbminter
dbminter
Master
Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)
Group: Forum Members
Posts: 1.2K, Visits: 12K
Yes, if you haven't, try editing your task(s) in Task Scheduler and enable Synchronize across time zones.  It's what's always fixed my problems with double running tasks.

BobUlius
BobUlius
Junior Member
Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)
Group: Forum Members
Posts: 48, Visits: 52
BTW, i was going to try "synchronize across time zones" but cannot find that setting anywhere in the definition file or task scheduler. Is that really the fix? And where might it be?

~Bob

dbminter
dbminter
Master
Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)
Group: Forum Members
Posts: 1.2K, Visits: 12K
Open Task Manager.  Double click on a task that is running twice.  Select the Triggers tab.  Select Edit at the bottom.  At the end of the Start line is a box you can check that says Synchronize across time zones.  Check that box.  Select OK.

BobUlius
BobUlius
Junior Member
Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)
Group: Forum Members
Posts: 48, Visits: 52
dbminter - 2 January 2020 12:04 AM
Open Task Manager.  Double click on a task that is running twice.  Select the Triggers tab.  Select Edit at the bottom.  At the end of the Start line is a box you can check that says Synchronize across time zones.  Check that box.  Select OK.


Thanks! Just could not find that. Now checked.

Is that really the valid fix for this issue. Have others found it to work?

Last time this happened in the spring, it ran twice one month after time change, then once a month after until this November time change. SO a little different than it was for me.

dbminter
dbminter
Master
Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)
Group: Forum Members
Posts: 1.2K, Visits: 12K
I found that it worked after someone else posted on here it worked for them.  I was skeptical, too, but I tried it, willing to try anything rather than delete and recreate scheduled tasks, and, to my complete surprise, it did work.


What used to work, as I said, was deleting the old scheduled backup and recreating it.  But, it only works until the next DST change, when the issue returns.  And you must delete the scheduled backups and recreate them again.  So, that works, too, but as you can tell, is a pain to have to do.

BobUlius
BobUlius
Junior Member
Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)
Group: Forum Members
Posts: 48, Visits: 52
dbminter - 2 January 2020 12:29 AM
I found that it worked after someone else posted on here it worked for them.  I was skeptical, too, but I tried it, willing to try anything rather than delete and recreate scheduled tasks, and, to my complete surprise, it did work.


What used to work, as I said, was deleting the old scheduled backup and recreating it.  But, it only works until the next DST change, when the issue returns.  And you must delete the scheduled backups and recreate them again.  So, that works, too, but as you can tell, is a pain to have to do.

Cool. I won't know until Feb 1, but agree that creating another scheduled backup is not my chosen way to go.
What happens with this checked and time changes? Does a 5AM schedule then run at 4 AM or 6 AM? Or does it stay at 5 AM?

Surprised Macrium hasn't implemented a fix. I was suprised to see this back again.

And thanks for the replies. Much appreciated.

dbminter
dbminter
Master
Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)Master (1.6K reputation)
Group: Forum Members
Posts: 1.2K, Visits: 12K
When I enabled Synchronize, one task runs at the scheduled time and no other times.


Macrium can't implement a fix because it's been a bug in Microsoft's Task Scheduler for years.  Microsoft refuses to address it, so there's nothing Macrium can do.


Although, Macrium has said they do plan on implementing their own task scheduler service at some point in the future to handle scheduled jobs.  No ETA on that feature, though.  I can't wait for it to be implemented, though, as long as it's implemented right.  With the ability to export and import jobs like Task Scheduler can.

BobUlius
BobUlius
Junior Member
Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)Junior Member (53 reputation)
Group: Forum Members
Posts: 48, Visits: 52
So let me ask then....

I have maybe 4 other tasks for Macrium in task scheduler but no others run twice. Should I enable sync for those even though they work as expected? Preventive maintenance?



GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search