Verification speed


Author
Message
FatMonkey
FatMonkey
New Member
New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)
Group: Forum Members
Posts: 31, Visits: 86
Nick,

Hi. You mentioned a few days ago that you guys were looking at the issue some of us have raised regarding significant slowdown in verification speed under v7 (vs. v6 and prior). Wondering whether you have any updates in regard to this...have you been able to duplicate these problems on your end?

Thanks for getting some of these other issues worked out.



JamieW
JamieW
Macrium Representative
Macrium Representative (349 reputation)Macrium Representative (349 reputation)Macrium Representative (349 reputation)Macrium Representative (349 reputation)Macrium Representative (349 reputation)Macrium Representative (349 reputation)Macrium Representative (349 reputation)Macrium Representative (349 reputation)Macrium Representative (349 reputation)Macrium Representative (349 reputation)
Group: Moderators
Posts: 252, Visits: 3.8K
Hi FatMonkey,

Unfortunately, we have not been able to reproduce the issue at all. In our testing lab, we can find no difference between V6 and V7 verification. We’ve also tried disabling CBT in V7 but the results are always within 30 seconds of each other.

Would you be kind enough to try uninstalling CBT to see if this has any impact on your verification times?

To uninstall CBT, please launch “mrcbttools.exe” which is normally located in “C:\Program Files\Macrium\Reflect\” and select “Remove CBT driver…” from the “File” menu. You will need to restart your computer to complete the removal process.

You can follow the same procedure to re-install CBT but replace “Remove CBT driver…” with “Install CBT Driver…”. Again, you will need to restart to complete the install process.

Kind Regards,
Jamie - Macrium Support

http://forum.macrium.com/uploads/images/0549dd73-fe70-418f-9277-e0bb.png


Kind regards,

Macrium Development

Next Webinar


FatMonkey
FatMonkey
New Member
New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)
Group: Forum Members
Posts: 31, Visits: 86
Jamie,

I ran an image backup test with verification after disabling/uninstalling CBT. No change. Verification time was roughly 25 minutes, which is about 1.5x the amount of time it took to do the initial backup (18 minutes). This verification duration was very close to the amount of time it was taking with CBT installed/enabled. This was a full image of an SSD, so I guess that I am not surprised that disabling CBT made no difference as my understanding is that CBT only applies to incremental and/or differential images/backup.

I am happy to run any other tests or send you my logs if that helps. Comment threads on the forums indicate that I am not the only one experiencing this issue.

The only other piece of relevant info that I have not mentioned previously is that I am running my backups with 192-bit AES encryption enabled. Have any changes been made to the encryption algorithm that might slow down the verification process?

Thanks.


Nick
Nick
Macrium Representative
Macrium Representative (3.6K reputation)Macrium Representative (3.6K reputation)Macrium Representative (3.6K reputation)Macrium Representative (3.6K reputation)Macrium Representative (3.6K reputation)Macrium Representative (3.6K reputation)Macrium Representative (3.6K reputation)Macrium Representative (3.6K reputation)Macrium Representative (3.6K reputation)Macrium Representative (3.6K reputation)
Group: Administrators
Posts: 2.1K, Visits: 13K
Hi FatMonkey

Thanks very much for getting back with those results. 

The only other piece of relevant info that I have not mentioned previously is that I am running my backups with 192-bit AES encryption enabled. Have any changes been made to the encryption algorithm that might slow down the verification process?


The AES implementation is unchanged but we will retest with similar settings. We have taken a look to see if there are any further optimisations that could be done in the I/O and we should be able to offer some speed improvement. However, this doesn't address why v7 isn't performing as well as v6. We are still investigating and will update you soon. 




Kind Regards

Nick - Macrium Support

Next Webinar


FatMonkey
FatMonkey
New Member
New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)
Group: Forum Members
Posts: 31, Visits: 86
Thanks Nick.

One final thought on my settings. I have the Macrium priority on all my backups set to "Highest". Even with this setting, I have noticed that CPU load during backup/verification is not particularly high (Macrium executable using typically < 10% of available CPU). I can't swear to this, but I think that under v6 I used to notice Macrium using more system resources if a backup/verification was ongoing while I was doing other stuff. So maybe some change has been made under v7 where the executables are not being granted as a high of a CPU priority/allocation. Not really sure why this might impact the verification step much more than the backup step, but thought I would mention it.

Appreciate you following this one up. Let me know if there is anything additional I can do to assist.



Edited 23 March 2017 4:43 PM by FatMonkey
FatMonkey
FatMonkey
New Member
New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)
Group: Forum Members
Posts: 31, Visits: 86
It appears that verification speed issues have been addressed/fixed w/release 2117. My verification times for an image backup are now back to about 2/3 the amount of time that the original image backup took. So...my total v7 imaging + verification times are in-line with what I was getting w/v6.
Thanks for getting this cleaned up.

GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search