Tray Icon & Notifications missing since 7.0.2055.


Author
Message
Chris-G
Chris-G
New Member
New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)
Group: Forum Members
Posts: 9, Visits: 103
I have like many others been having a few problems since upgrading to Macrium Reflect V7. Most of these (backups to NAS) seem to have been resolved, however one problem I didn’t have, now seems to have become apparent.

I never had a problem with the Notifications and Tray Icon during scheduled backups until Version 7.0.2055. Now I’m finding that the notifications and icon are usually missing. I say usually, because on occasions I do get the notifications and icon!!!

I have tried deleting and re-entering the schedules from within Macrium, and this makes no difference.Looking at the Task Scheduler I see that all Macrium tasks are run under the account SYSTEM and Reflect.exe has the switches -e -w. The last time I noticed the notifications working OK was during a Full backup. I don’t know if this was a fluke or would always happen, or if its just sequential backups with the problem!

I’m currently using Version 7.0.2079.


Nick
Nick
Macrium Representative
Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)
Group: Administrators
Posts: 2.2K, Visits: 13K
Hi 

Thanks for posting. Sorry you are having problem. 

Reflect runs using the SYSTEM account to execute scheduled backups. A small process called ReflectUI.exe that runs in the context of the logged on user runs the process ReflectMonitor.exe. ReflectMonitor.exe creates the TaskBar icon and provides the backup progress dialog. 

Note: You can launch the progress dialog at any time by pressing Ctr+Alt+M.

First check to make sure that the icon hasn't been hidden by checking the 'Notification Settings' in the 'Taskbar Settings. 

If that doesn't help change the following registry entries with RegEdit:

HKEY_CURRENT_USER\SOFTWARE\macrium\reflect\ReflectMonitor

There are two values, 'TrayIcon' with a binary value and 'Error; which will be blank if the icon was created or contain an error description if the icon creation failed:

http://forum.macrium.com/uploads/images/96cdca76-438d-4849-a594-0d33.png

Can you let us know what value, if any, exists for the 'Error' entry. 

Kind Regards

Nick - Macrium Support

Next Webinar


FatMonkey
FatMonkey
New Member
New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)
Group: Forum Members
Posts: 31, Visits: 86
Nick,
The ReflectMonitor entry in my registry only has two values: (Default) and WindowPlacement. There are no TrayIcon or Error entries.
As an aside, there is an additional entry HKEY_CURRENT_USER\SOFTWARE\Macrium.ReflectMonitor\reflectmonitor\ReflectMonitor, which has the same two entries (Default) and WindowPlacement mentioned above (although the binary value in the two WindowPlacement entries is different. Screenshot below:

Nick
Nick
Macrium Representative
Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)
Group: Administrators
Posts: 2.2K, Visits: 13K
Hi 

Thanks for that information. 

Unfortunately that't the wrong key. Do you have a ReflectMonitor key under SOFTWARE\Macrium\Reflect?    

HKEY_CURRENT_USER\SOFTWARE\macrium\reflect\ReflectMonitor


Kind Regards

Nick - Macrium Support

Next Webinar


FatMonkey
FatMonkey
New Member
New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)
Group: Forum Members
Posts: 31, Visits: 86
Nick,
Sorry...found the right one.
There is no value listed for the "Error" key:



Nick
Nick
Macrium Representative
Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)Macrium Representative (3.7K reputation)
Group: Administrators
Posts: 2.2K, Visits: 13K
Thanks for that. 

There's no problem with the icon creation. 

Can you see if the icon is displayed when a scheduled backup is running when 'Show All Icons' is set for the Windows Task Bar:

https://www.tenforums.com/tutorials/5313-notification-area-icons-hide-show-windows-10-a.html

Additionally, can you confirm that Ctrl+Alt+M brings up the progress dialog when a scheduled backup is running. 

Many Thanks

Kind Regards

Nick - Macrium Support

Next Webinar


FatMonkey
FatMonkey
New Member
New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)
Group: Forum Members
Posts: 31, Visits: 86
Nick,
I added a scheduled backup to test...
After the backup starts, there is NO Macrium icon showing:

However, if I then do a CTRL-ALT-M it brings up both a dialog box and at that point causes the icon to appear (you can see the icon is the left-most icon on my taskbar). However, as you can see below, the dialog box is blank and does not show the progress of the backup that is currently underway. Under v6 when I would right-click the Macrium icon and select "show", it would bring up a dialog box that showed me relevant statistics about current backup progress (i.e. the dialog box was not blank like it is in v7).

Hope that helps.

FatMonkey
FatMonkey
New Member
New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)New Member (42 reputation)
Group: Forum Members
Posts: 31, Visits: 86
Nick,
I just noticed that there is already an open thread related to the blank dialog window for a backup in progress (http://forum.macrium.com/Topic12295.aspx). FWIW I am running Windows Defender as my AV and do in fact already have both ReflectBin.exe and ReflectMonitor.exe in my exclusion list.

Chris-G
Chris-G
New Member
New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)
Group: Forum Members
Posts: 9, Visits: 103
Sorry I didn’t get back straight away after the fast response from Nick but I’ve been having internet problems for the past few days.

Since my original post, all notifications during scheduled backups have been working, which means that my original thought of type of backup, i.e. full, sequential (different schedule task) etc is erroneous. However it also means that I have been unable to do any of the suggestions to find the problem.

I note that there has been an update to Version 7.0.2089 (which I am now using). Does the Backup progress not displayed bug fix include this problem or should I be continuing to trying to create / monitoring for this problem?


RayG
RayG
Advanced Member
Advanced Member (595 reputation)Advanced Member (595 reputation)Advanced Member (595 reputation)Advanced Member (595 reputation)Advanced Member (595 reputation)Advanced Member (595 reputation)Advanced Member (595 reputation)Advanced Member (595 reputation)Advanced Member (595 reputation)Advanced Member (595 reputation)
Group: Forum Members
Posts: 292, Visits: 1.3K
Nick - 20 March 2017 7:53 PM
Hi 

Thanks for that information. 

Unfortunately that't the wrong key. Do you have a ReflectMonitor key under SOFTWARE\Macrium\Reflect?    

HKEY_CURRENT_USER\SOFTWARE\macrium\reflect\ReflectMonitor

@Nick

Just for interest I looked at this key and found this as the entry. Should it be doubled up?
HKEY_CURRENT_USER\SOFTWARE\macrium\reflectmonitor\ReflectMonitor
There are no entries at all under either key. Should this one be there at all?


Regards
RayG
Windows10 Pro X64 V20H2 B19042.630 MR v7.3.5365

Edited 23 March 2017 3:41 PM by RayG
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search