Scheduling is always at 9:30 pm now when I use to have it set for 3:30 am


Scheduling is always at 9:30 pm now when I use to have it set for 3:30...
Author
Message
max2
max2
Proficient Member
Proficient Member (200 reputation)Proficient Member (200 reputation)Proficient Member (200 reputation)Proficient Member (200 reputation)Proficient Member (200 reputation)Proficient Member (200 reputation)Proficient Member (200 reputation)Proficient Member (200 reputation)Proficient Member (200 reputation)Proficient Member (200 reputation)
Group: Forum Members
Posts: 109, Visits: 243
It won't change either after I set it to 3:30 am. It just goes back to 9:30 pm. How can I fix this please? Thanks. I tried deleting and re-adding a scheduled task no help.

jphughan
jphughan
Macrium Evangelist
Macrium Evangelist (18K reputation)Macrium Evangelist (18K reputation)Macrium Evangelist (18K reputation)Macrium Evangelist (18K reputation)Macrium Evangelist (18K reputation)Macrium Evangelist (18K reputation)Macrium Evangelist (18K reputation)Macrium Evangelist (18K reputation)Macrium Evangelist (18K reputation)Macrium Evangelist (18K reputation)
Group: Forum Members
Posts: 12K, Visits: 72K
max2 - 27 February 2017 11:31 PM
It won't change either after I set it to 3:30 am. It just goes back to 9:30 pm. How can I fix this please? Thanks. I tried deleting and re-adding a scheduled task no help.

Reflect is for some reason interpreting the time you specify as UTC, and it sounds like your time zone is UTC -6, so when you enter 3:30AM it sees "3:30AM UTC", which in your local time is 9:30PM (the previous day).  In another thread a Macrium developer said yesterday that an update to resolve not taking time zones into account properly would be released soon. Just for technical curiosity though I would love to know why Reflect even needs to concern itself with time zones.  I'd have thought that it would just look at the system clock to determine when to execute and never have to deal with time zones.   I don't think Windows Task Scheduler deals with time zones; if I create a scheduled task on my laptop for 8PM while at home and then travel to another time zone and update my OS settings accordingly, I'm fairly certain that Windows continues to run that task at 8PM local time, not 8PM in the original time zone.
                               
Mike A
Mike A
Macrium Representative
Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)
Group: Forum Members
Posts: 133, Visits: 500
Hi max2,

There was a problem with the initial release of Reflect v7 where it didn't take into account the timezone correctly. A new release is available (build 2001) that ensures that new scheduled tasks are created correctly.

Thanks,

Mike.
schrader
schrader
New Member
New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)
Group: Forum Members
Posts: 4, Visits: 3
I have the latest release. The problem is not resolved. I set my scheduled backup to 00:00 but it occurs at 08:00 as I live in Malaysia. 

Mike A
Mike A
Macrium Representative
Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)Macrium Representative (331 reputation)
Group: Forum Members
Posts: 133, Visits: 500
Hi schrader,

Which build are you running? Also if you edit each schedule within Reflect, this will sync the tasks with Windows Task Scheduler.

Thanks,

Mike.
schrader
schrader
New Member
New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)New Member (4 reputation)
Group: Forum Members
Posts: 4, Visits: 3
Hi Mike,
Yes after I edit each schedule everything is ok.
Thanks for your help,
David
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search