Command line verification program exits immediately


Author
Message
bpburns88
bpburns88
New Member
New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)
Group: Forum Members
Posts: 3, Visits: 8
I have a problem using the mrverify.exe command line tool. Sometimes the tool works as expected, verifying the backup image and reporting whether the verification was successful. Other times, it seems to get into a state where the tool returns immediately and reports success when it could not possibly have loaded and scanned the whole backup set from disk. Running the verification from the Macrium Reflect GUI works as expected. The odd behavior with the command line tool happens whether or not the backup image is password-protected and whether or not I ask the tool to verify the whole set or just a single image. The problem also happens with both disk images and File and Folder backups. The problem also happens regardless of whether the backup image is on a direct-attached hard drive or being loaded over the network.

Interestingly, for backups that are password-protected, the tool will fail and complain that the password was incorrect if I deliberately enter an incorrect password. Therefore, it seems the tools is at least loading enough of the backup header to verify the password, but is not proceeding any further. I have not tried deliberately corrupting a backup image to test if the tool would also detect this, but since it is evidently not loading the entire backup before returning, I assume that there are cases where it would not detect a corrupted backup.

This is especially troubling where I want to automate routine backup image verification. A human sitting at the command prompt can easily see that something is wrong, but an automated script would miss these false positive verifications.

Any help anyone can provide is appreciated.
Edited 22 December 2016 6:36 PM by bpburns88
Nick
Nick
Macrium Representative
Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)Macrium Representative (3.8K reputation)
Group: Administrators
Posts: 2.2K, Visits: 13K
Hi 

Thanks for posting. Sorry you are having problems.  

So we can see the parameters you are using and the MRVerify.exe output can you add the log parameter and attach the problem log to a support ticket:

http://www.macrium.com/support.aspx#tickets


Kind Regards

Nick - Macrium Support

Next Webinar


GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search